Zonedirector version 10.1 (1200/3000) problems with auto-upgrade of APs

  • 1
  • Question
  • Updated 7 months ago
  • (Edited)
When adding APs that were originally on 9.[10-13] and adding them to a ZD 1200 or 3000 running 10.X firmware, they fail to upgrade. I should explain, I am in the events industry and we send out various different ZDs to different events and preconfigure the ZDs from a template before they go out. We have a mixture of old and new APs which mean we need to use 9.X on certain events and 10.X on others. 
An example message in the log is as follows:
Failed to upgrade AP[xx:xx:xx:xx:xx:xx] image from [9.12.3.0.61] to [10.1.0.0.1515] after [16] retries
The only way around this (that we've found) is to flash the APs with the latest standalone firmware (104.X) and then they upgrade successfully, but as you can imagine doing this with 10s or potentially hundreds of APs, individually, is a massive pain in the bum.
I've had this problem with 7372s 7982s R500s and R700s.

We need some sort of resolution to this other than upgrading them all manually first.

Factory resetting the APs makes no difference.

Any suggestions, or ways of doing mass-upgrades of APs?

Thanks
Photo of Chris Clancey

Chris Clancey

  • 6 Posts
  • 1 Reply Like
  • frustrated

Posted 7 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2584 Posts
  • 353 Reply Likes
Hello Chris,



    The current ZD 10.1.0.0.115 Release Notes, say you need to be on 9.13.x before going

to this 10.1 release.  If you have APs on 9.10.x or 9.12.x you would need an interim upgrade

to 9.13.x first.

https://support.ruckuswireless.com/documents/2149-zonedirector-10-1-0-ga-release-notes

    You mentioned 9.[10-13] though, so have you had problem with 9.13.x to 10.1 and if so,

was it any particular model of AP?  These should all have been verified by QA before release,

but customers environments may vary from our labs.

(Edited)