ZoneDirector 1100 and VLANs

  • 1
  • Question
  • Updated 1 year ago
Hello,

I have a ZoneDirector 1100, I have a few SSID's on differrent VLANs...........this is my port configs.........

ZoneDirector 1100 port config is:

interface GigabitEthernet3/0/2
 description Ruckus1100 Controller
 switchport access vlan 5
 switchport mode access
 logging event spanning-tree
 macro description har_mgmt
 spanning-tree portfast
 spanning-tree bpduguard enable
end

AP port config is:

interface GigabitEthernet2/0/2
 description WAP Access point
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,24,32,40,44,56,72
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 macro description har_WAP
 auto qos trust

I've created 1 SSID called staff and configured the VLAN on the controller with vlan id 24

Does the above look correct?
Photo of Ian Taylor

Ian Taylor

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Ian Taylor

Ian Taylor

  • 5 Posts
  • 0 Reply Likes
Hi, just to update I have managed to get this working with the config below:

interface GigabitEthernet3/0/2
 description Ruckus1100 Controller
 switchport access vlan 5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport trunk allowed vlan 5,24,32,40,44,56,72
 switchport mode trunk
 spanning-tree portfast
end

AP:

 description WAP Access point
 switchport access vlan 5
 switchport trunk allowed vlan 5,24,32,40,44,56,72
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust

I am picking up the correct IP for the VLAN etc
Photo of Bill Burns

Bill Burns, AlphaDog

  • 203 Posts
  • 38 Reply Likes
I think you're missing "switchport mode trunk" on your WAP port.
And your WAP port config looked more correct the first time around.
(with "switchport native VLAN 5" in place)

Assuming that your ZoneDirector lives in a subnet on VLAN 5:
I would recommend for its port:
"switchport access vlan 5"
and
"switchport mode access"

Again this is more consistent w/ your *original* config, not your update.
..and this is a bit dependant on your ZoneDirector configs.
There are other (non-default) ways to configure your ZoneDirector that would require different switch configs.