ZF-7962- Just want to create a simple guest wireless connection

  • 1
  • Question
  • Updated 3 years ago
I have a ZF-7962, love it.
I want to have 2 wireless connections. 1 for users on the domain and one for guests.My wireless connection for domain users works fine. Guest wireless does not.

I have setup a local subnet under on the ZF, but I am not sure how to give it access to the internet through the AP.

Here is how it is setup:
Local subnet:
192.168.40.1
255.255.255.0
Starting address: 192.168.40.2
Access VLAN 40

Static IP set up for Internet settings.

Wireless 2.4:
Wireless1 (working) Packet forward (Bridge to Wan) Access VLAN 1
Wireless2 (not working) Packet forward (local subnet NAT and Route to Wan)
Local Subnet: Local Subnet 1
Access VLAN 40

What am i missing?
Photo of Dan Bantner

Dan Bantner

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Are you using the same local subnet for both WLAN's? If so, create another local subnet for Wireless2 (different IP address and DHCP scope) and that should work for you.
Photo of Dan Bantner

Dan Bantner

  • 5 Posts
  • 0 Reply Likes
Quite frankly I don't understand how the local subnet identifies with the ethernet connection to the AP.

The main wireless connection works because in my main internet setting on the AP I can say , hey here is the gateway. Go to the internet through that.

But when I set up a local subnet, set the Access VLAN to 40 (as the manual suggested) it just doesn't work. When you go into the Wireless settings for your Guest Wireless, and you select Local Subnet NAT and ROute to Wan, the Access VLAN is not there. Just the Local Subnet 1

So how does it know where to send the traffic?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Sorry, I think I gave you a stupid answer. How is your Ethernet setup?
Photo of Dan Bantner

Dan Bantner

  • 5 Posts
  • 0 Reply Likes
I have a standard ethernet connection going into port 2.
Port 2 is currently setup as Access Port and Bridge to WAN.
VLAN untag ID 1
nothing else
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
So..can think of 2 things.

1) If you are connecting to a modem and not a router, it's only going to give you a single IP address. You already consumed that with Wireless1. So you would need a router for this to work. However...(and this is where my first answer comes in) if you set up a local subnet for everything except the ethernet connected to your modem, it should work. Just make sure and use different subnets on each (and set the DHCP server as well)

2) Just set the VLAN's all to 1 (the untagged) - I don't think this is the issue but it's worth a shot and won't hurt anything.
Photo of Dan Bantner

Dan Bantner

  • 5 Posts
  • 0 Reply Likes
But if I do it that way, with 2 different subnets, I am not going to be able to access the network, because both subnet will be different than my network subnet.

So, to set this up properly, I will need to configure that second subnet (guest wireless) to route to the internet only. And that is not done on the AP, it's done on the router side, correct?
Photo of Dan Bantner

Dan Bantner

  • 5 Posts
  • 0 Reply Likes
I mean, because there is not point in having 2 different subnets if I can't establish where each of them is going. Subnet1 has access to everything, subnet2 has access to internet only. And I am not sure if, the Ruckus AP supports that.
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Yes, lost some context in the thread but you are correct that the AP by itself won't support this. I think there's a way using a router and some tricks w DHCP to do it but need to play around w it.