ZF7343 with AppleTV3 and iPad 3 - AirPlay very unreliable

  • 2
  • Question
  • Updated 4 years ago
Hi there,

A home network is set up with a ZF7343 AP (no ZoneDirector) for wifi access (firmware version 9.6.1.0.15), and for the most part, this works extremely well - wireless performance is excellent even when many many devices are online.

However, there is an Apple TV 3 (current firmware) that we're having trouble to get AirPlay to work consistently with. There are two iPhones (4S and 5) and two iPads (2 and 3) commonly used in this house. All of them see AirPlay available only every now and then, mostly right after the iOS device or the ATV unit have been rebooted, but not always then either.

Once they do see AirPlay on their units, playback is smooth, but sometimes it just disappears.

No password for the AirPlay functionality is defined.

Neither the ATV nor the i*-devices have any general network trouble - they can access for instance Netflix with no problems.

"Packet Forward" for the WLAN being used is set to "Bridge to WAN". Since both the ATV and the iOS devices are connected through WLAN, I'm thinking the problem could be here, but that is just a guess.

Any ideas on how I could approach this?

Very thankful for any suggestions!
Photo of Rune Jacobsen

Rune Jacobsen

  • 5 Posts
  • 0 Reply Likes
  • sad

Posted 4 years ago

  • 2
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
Hi Rune, sorry for the delay. I'm going to guess this has something to do with directed multicast. In wireless you don't want "true" broadcast/multicast typically in order to preserve bandwidth. This article should help - https://support.ruckuswireless.com/answers/000001588
Photo of Rune Jacobsen

Rune Jacobsen

  • 5 Posts
  • 0 Reply Likes
Hi Keith,

Thanks for your reply!

I tried to follow the article, and used putty to ssh in. But the commands in the article didn't work - could this be because I have a later version?

The one that looked the most like what is described in the article was this one:

set qos directed multicast {enable|disable}
-- Sets the state of egress packet processing for the specified interface

So since my AP is connected to eth2, I did this:

set qos eth2 directed multicast disable

But nothing else. The issue is still there, but of course I have a few more questions;

1) Was that the right command to use? In mine I had to specify the ethernet interface, in the one on the web they said to specify the ssid.

2) Do I need to do anything equivalent of "enable" to get the setting to take effect?

Thanks for the help so far, hoping I'm just a few technicalities away from permanently working AirPlay. :)
Photo of Rune Jacobsen

Rune Jacobsen

  • 5 Posts
  • 0 Reply Likes
I read up a little more on this, and understood that I should probably do it on wlan0 (the WLAN I actually use) instead of eth2... I think I did it, but no airplay, except that it shows up randomly now and then.

rkscli: get qos wlan0
Ruckus Wireless SmartMedia QOS info for wlan0 interface

QOS Configuration options:
Classification: Enabled
UDP Heuristic Classification: Enabled
TOS Classification: Enabled
Dot1p Classification: Enabled
VID Voice Classification:
VID Video Classification:
VID BE Classification:
VID BK Classification:
Dot1p Classification VIDs:
Dot1p Marking VIDs:
Directed Multicast: Disabled
IGMP Snooping Mode: Enabled
MLD Snooping Mode: Disabled

General Mcast->U Cloned Filters TOS-Mark
Stats 14 14 0/0/0 0/0/0/0

L2 Mcast Packets Unicast Unk-Drop Known-Mcast
UDP Data 79855 28 79841 307590

Heuristics Voice Video
UDP Packets 423 0

IGMP/MLD Clone1/2/3
Errors 0/0/0

No Filters are currently defined on wlan0 interface
OK
rkscli:

Any ideas? Should I do a Wireshark capture to see what is going wrong? In that case, how to do that from a single AP?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
Sorry Rune - I sent you the ZD CLI commands and the AP's are a bit different:

Standalone AP:
set qos wlanX directed multicast disable
set directed-thr wlanX 0

where X is the wlan AirPlay is on, use ‘get wlanlist’ to see configured WLANs.
Photo of Rune Jacobsen

Rune Jacobsen

  • 5 Posts
  • 0 Reply Likes
Hi Keith,

These were the commands I eventually arrived at as well.

Unfortunately, still no AirPlay most of the time. If I keep resetting/rebooting both the Apple TV and the iPad 3, AirPlay some times show up, and will work for 20-30 minutes at a time, but no more than that.

I don't want to bite the bullet and put the ATV on ethernet.. but is there any way to see what gets "blocked"?
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 51 Reply Likes
We're going to need to dig deep on this one, so best would be to open a support request - https://support.ruckuswireless.com/co...
Photo of Rune Jacobsen

Rune Jacobsen

  • 5 Posts
  • 0 Reply Likes
Thanks Keith - will do that!

I am wiresharking on a tap connected to the 7343 now, and will hopefully produce something that support can find useful.

Thanks for your help so far!
Photo of Tim Arthur

Tim Arthur

  • 2 Posts
  • 0 Reply Likes
Curious if this was ever resolved with a "workaround fix" or by a FW update?

I am having the same issue. Except my apple TV is connected to the network via an ethernet cable.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2114 Posts
  • 297 Reply Likes
Every environment is different and depending on how many clients were using
Airplay on the single standalone 7343, leaving directed-multicast on might have
been ok.

Good news for Apple users, upgrade to version 9.7 firmware, which re-classifies
Bonjour/mDNS protocol traffic into the deeper Data QoS queue, over Background/
Best Effort in previous releases. The upgrade alone may provide the improvement
you're looking for.

[ If you have tweaked all kinds of Eth/Wifi0 parameters, you might also consider
a factory default of your AP, and setup your WLAN(s) again. ]
Photo of Steve LeBoeuf

Steve LeBoeuf

  • 1 Post
  • 0 Reply Likes
I am having the same issue. We have several Apple TVs (10+) connected to televisions around the office and access to them is spotty at best. I've been very happy with Ruckus APs up to this point but it's a little embarrassing when people tell me it "used to work great" when we were only using an Apple Airport access point.

We have four ZF 7372 access points installed around the building (no ZoneDirector). Each is using the same SSID for the main WLAN. AP bridge is enabled on the wlan, and I've confirmed that directed multicast is disabled, as mentioned above. All four APs are running 9.7.0.0.220. Any Apple TVs that are hardwired seem to work properly but any that use the wireless network disappear or fail to work properly most of the time.

We've also noticed a similar issue when using Reflector (by AirSquirrels) to mirror an iPad to a desktop computer. Users repeatedly complain their iPads can't see the desktop when using Airplay with the wireless.

Rebooting the access points will sometimes work but only about 50% of the time and it never lasts.

Are there any updates or new solutions to this issue?