Windows CE 6.0 Client disconnects and joins instead of roaming

  • 1
  • Question
  • Updated 2 years ago

Hi,

We have ZD1200 (9.10.0.0. 218)with multiple AP's (R700, R500, 7982, R300).
Client (Datalogic Skorpio X3) with Windows CE 6.0 (Barcode Scanner)

Both AP's are close enough and under ZD control. AP's distance is about 20m.

When client moves between AP's I see logs from ZD that it leaves and joins instead of roaming.

2015/06/02  15:15:34 Low   User[00:17:23:ac:a6:d7] joins WLAN[Standard Terminal] from AP[ADM_R300_8K_02]
2015/06/02  15:15:34 Low   User[00:17:23:ac:a6:d7] leave WLAN[Standard Terminal] at AP[ADM_7982_8K_01] with Session Time[96.43 sec] RX Bytes[940] TX Bytes[602]
2015/06/02  15:15:34 Low   User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Terminal] at AP[ADM_7982_8K_01]
2015/06/02  15:13:57 Low   User[00:17:23:ac:a6:d7] joins WLAN[Standard Terminal] from AP[ADM_7982_8K_01]
2015/06/02  15:13:57 Low   User[00:17:23:ac:a6:d7] leave WLAN[Standard Terminal] at AP[ADM_R300_8K_02] with Session Time[813.28 sec] RX Bytes[940] TX Bytes[602]
2015/06/02  15:13:57 Low   User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Terminal] at AP[ADM_R300_8K_02]
2015/06/02  15:00:24 Low   User[00:17:23:ac:a6:d7] joins WLAN[Standard Terminal] from AP[ADM_R300_8K_02]
2015/06/02  15:00:21 Low   User[00:17:23:ac:a6:d7] leave WLAN[Standard Terminal] at AP[ADM_R300_8K_02] with Session Time[6.70 sec] RX Bytes[884] TX Bytes[602]
2015/06/02  15:00:21 Low   User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Terminal] at AP[ADM_R300_8K_02]
2015/06/02  15:00:15 Low   User[00:17:23:ac:a6:d7] joins WLAN[Standard Terminal] from AP[ADM_R300_8K_02]

When I move between those AP's with my Android Phone I see:

2015/06/02  15:47:51 Low   AP[ADM_7982_8K_01] radio [11g/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams out to AP[ADM_R700_1K_01]
2015/06/02  15:47:05 Low   AP[ADM_7982_8K_01] radio [11g/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams from AP[ADM_R300_8K_02]
2015/06/02  15:47:05 Low   AP[ADM_R300_8K_02] radio [11g/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams out to AP[ADM_7982_8K_01]
2015/06/02  15:46:00 Low   AP[ADM_R300_8K_02] radio [11g/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams from AP[ADM_7982_8K_01]
2015/06/02  15:46:00 Low   AP[ADM_7982_8K_01] radio [11a/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams out to AP[ADM_R300_8K_02]
2015/06/02  15:45:36 Low   AP[ADM_7982_8K_01] radio [11a/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams from AP[ADM_R300_8K_02]
2015/06/02  15:45:36 Low   AP[ADM_R300_8K_02] radio [11g/n] detects User[f0:27:65:79:40:37] in WLAN[Standard Public] roams out to AP[ADM_7982_8K_01]

Can anyone explain why is that? Or what's wrong?

Photo of janx

janx

  • 27 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 760 Posts
  • 163 Reply Likes
Hi Janx,

wondering whats different between Standard Public and Standard terminal wlan?
If there are same or somewhat similar then can you swap the tests and see if there is any difference?
which firmware version in use? which model of ZD?
Did you enable roaming related features on the controller that "may" help?
Photo of janx

janx

  • 27 Posts
  • 0 Reply Likes

Public uses "WPA-Mixed" and algorithm "Auto" encryption. This is dedicated network for our BYOD devices.

Terminal uses "WPA2" and algorithm "AES" encryption. This is dedicated network for our barcode scanners (terminals).

Also, I don't know I'm I able to compare relatively new Android and Windows CE 6.0 (basically launched 2006) devices... The device itselt (barcode scanner) is brand new device, but the OS is quite old..

Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 760 Posts
  • 163 Reply Likes
ok janx can you try roaming the handheld on public or clone it for testing or may be make WLAN as open to see if that throws up new results...
Photo of janx

janx

  • 27 Posts
  • 0 Reply Likes

Tried.

Same thing:

2015/06/03  11:00:03Low User[00:17:23:ac:a6:d7] joins WLAN[Standard Public] from AP[ADM_7982_8K_01]2015/06/03  11:00:03Low User[00:17:23:ac:a6:d7] leave WLAN[Standard Public] at AP[ADM_R700_8K_02] with Session Time[22.26 sec] RX Bytes[1596] TX Bytes[2257]2015/06/03  11:00:03Low User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Public] at AP[ADM_R700_8K_02]2015/06/03  10:59:40Low User[00:17:23:ac:a6:d7] joins WLAN[Standard Public] from AP[ADM_R700_8K_02]2015/06/03  10:59:40Low User[00:17:23:ac:a6:d7] leave WLAN[Standard Public] at AP[ADM_7982_8K_01] with Session Time[39.85 sec] RX Bytes[2814] TX Bytes[1853]2015/06/03  10:59:40Low User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Public] at AP[ADM_7982_8K_01]2015/06/03  10:59:00Low User[00:17:23:ac:a6:d7] joins WLAN[Standard Public] from AP[ADM_7982_8K_01]

This device seems to be able to roam between channels in one access point:

2015/06/03  09:31:12Low AP[ADM_7982_8K_01] radio [11g/n] detects User[00:17:23:ac:a6:d7] in WLAN[Standard Terminal] roams from AP[ADM_7982_8K_01]2015/06/03  09:31:12Low AP[ADM_7982_8K_01] radio [11a/n] detects User[00:17:23:ac:a6:d7] in WLAN[Standard Terminal] roams out to AP[ADM_7982_8K_01]2015/06/03  09:26:39Low AP[ADM_7982_8K_01] radio [11a/n] detects User[00:17:23:ac:a6:d7] in WLAN[Standard Terminal] roams from AP[ADM_7982_8K_01]
Photo of janx

janx

  • 27 Posts
  • 0 Reply Likes
Also no difference if WLAN is Open - no authentication at all.
Photo of janx

janx

  • 27 Posts
  • 0 Reply Likes

I saw one indication of roaming. Why only one. The others are joining and leaving:

2015/06/03  11:14:47 Low   AP[ADM_7982_8K_01] radio [11g/n] detects User[00:17:23:ac:a6:d7] in WLAN[Standard Terminal] roams from AP[ADM_R700_8K_02]
2015/06/03  11:14:47 Low   AP[ADM_R700_8K_02] radio [11g/n] detects User[00:17:23:ac:a6:d7] in WLAN[Standard Terminal] roams out to AP[ADM_7982_8K_01]
2015/06/03  11:14:47 Low   User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Terminal] at AP[ADM_R700_8K_02]
2015/06/03  11:14:25 Low   User[00:17:23:ac:a6:d7] joins WLAN[Standard Terminal] from AP[ADM_R700_8K_02]
2015/06/03  11:14:25 Low   User[00:17:23:ac:a6:d7] leave WLAN[Standard Terminal] at AP[ADM_7982_8K_01] with Session Time[143.07 sec] RX Bytes[2064] TX Bytes[2069]
2015/06/03  11:14:25 Low   User[00:17:23:ac:a6:d7] disconnects from WLAN[Standard Terminal] at AP[ADM_7982_8K_01]
 

Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 760 Posts
  • 163 Reply Likes
i would suggest some more stuff to try on both sides, client and controller to see if that makes a different:

1. play with roaming aggressiveness on the terminals.
2. enable Fast BSS roaming, I am seeing this feature on 9.8.0.0 build 1725 so please chk ur controller.
3. try to put same channel on both AP's n try the test again to see if it helps...

hope this helps..