Wi-Fi Calling on Unleashed

  • 1
  • Question
  • Updated 4 weeks ago

First I just want to say thank you for adding this to Unleashed!  I have configured a Profile for this and enabled it on a WLAN, but I am not seeing my Wi-Fi Calling Client, even after refreshing, on the Summary tab even though I’m currently on a Wi-Fi Call.  How do I go about troubleshooting this?

Thank you!

Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes

Posted 2 months ago

  • 1
Photo of Tony Heung

Tony Heung, Official Rep

  • 65 Posts
  • 16 Reply Likes
Can you share the profile you created?  And a screenshot on the WLAN that you had enabled it.
Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes
Sure Tony:



Photo of Tony Heung

Tony Heung, Official Rep

  • 65 Posts
  • 16 Reply Likes
Thanks Daniel.  It looks good.  To rule out the possible DNS factor, try to add the first entry TMobile (ss.epdg.epc.mnc260.mcc310.pub.3gppnetwork.org) with the ip 208.54.88.35 and second entry Verizon (233.sub-141-207-229.myvzw.com) with ip 141.207.229.233.  Even though the ip address is optional but worth to test.  I think the Verizon one been pretty much static to this ip but TMobile been changing depending on location, you can use the host ss.epdg.epc.geo.mnc260.mcc310.pub.3gppnetwork.org as it includes the geo subdomain for the dns lookup based on your location for the closest ePDG server ip address.

Another test you can try is to just keep one server line in your Wi-Fi Calling profile, just a better controlled setup for troubleshooting for now.

If you are not 100% sure if your operator supports Wi-Fi Calling (suppose you did see the Wi-Fi Call icon on your phone),  you can start a Wireshark capture on or behind the AP and then activate Wi-Fi calling on the device to capture the FQDN that the device is looking for and can use that for your profile.  
Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes

Hey Tony!

In reviewing your reply, I did the following:

  • Used tcpdump to verify the DNS lookup that the Wi-Fi Calling client is using
  • Used tcpdump to confirm IPsec connectivity for Wi-Fi Calling
  • Confirmed adding an IP Address for the ePDG does not change the behavior
  • Confirmed adding the actual IP Address that my Wi-Fi Calling client is actually using for the ePDG does not change the behavior
  • Confirmed using one ePDG/server does not change the behavior


Some more detail:

The actual DNS lookup performed by the Wi-Fi Calling client is:

$ sudo tcpdump -ni vlan19 host 198.51.100.200 and port 53
tcpdump: listening on vlan19, link-type EN10MB
...
13:06:02.082764 198.51.100.200.42157 > 198.51.100.254.53: 24301+ A? epdg.epc.mnc260.mcc310.pub.3gppnetwork.org.(60) (DF)

The host above as well as ss.epdg.epc.mnc260.mcc310.pub.3gppnetwork.org are just CNAMEs for their respective “geo” names:

$ host -t A epdg.epc.mnc260.mcc310.pub.3gppnetwork.org
epdg.epc.mnc260.mcc310.pub.3gppnetwork.org is an alias for epdg.epc.geo.mnc260.mcc310.pub.3gppnetwork.org.
epdg.epc.geo.mnc260.mcc310.pub.3gppnetwork.org has address 208.54.37.80
$ host -t A ss.epdg.epc.mnc260.mcc310.pub.3gppnetwork.org
ss.epdg.epc.mnc260.mcc310.pub.3gppnetwork.org is an alias for ss.epdg.epc.geo.mnc260.mcc310.pub.3gppnetwork.org.
ss.epdg.epc.geo.mnc260.mcc310.pub.3gppnetwork.org has address 208.54.83.96

The IP addresses returned for epdg.epc.geo.mnc260.mcc310.pub.3gppnetwork.org and related are highly dynamic, change frequently and have a very short TTL.. 

Lastly, after changing the ePDG to epdg.epc.mnc260.mcc310.pub.3gppnetwork.org, which is what the client actually uses, the web UI started to populate for some reason, but it’s not clear why; it is also very possible my testing results are highly skewed due to the delay between when a change is made and what’s reflected in the Wi-Fi Calling Summary tab.  Subsequent Wi-Fi calls appear to eventually get reflected in the web UI—they don’t readily show up with frequent refreshes—but this is definitely not reflected in real-time and this hampers troubleshooting.  I guess I’ll consider the matter closed for now unless you are interested in me trying some more things.

Are there any command line operations I can run on the AP to gain greater insight that might be omitted or delayed in relation to the web UI?

Thanks Tony!



(Edited)
Photo of Tony Heung

Tony Heung, Official Rep

  • 65 Posts
  • 16 Reply Likes
Thank you Daniel for the detailed troubleshooting you did, and glad to hear the Wi-Fi Calling feature is working flawlessly.  One reason why I like Ruckus AP is the level of technical deep dive you could do from the CLI.

See below an example on how to validate in real-time the QoS is applied correctly from the output of “get rflow” from AP CLI.  The flow you need to identify is the one with port 4500/udp and you should see the name of the ePDG in the APP column.  Assuming the Wi-Fi Calling profile is set to voice (which you did) rather than QoS as "-1" you should have "3" under QoS.

rkscli: get rflow 
| flag | age | MAC1  MAC2 | IP1                 IP2      | proto|PORT1 PORT2 | flow ID | 1tx  1rx | Deny |     QoS    |  R/L |    URL    |         APP         | 2tx  2rx  | retry | UTP  | ifname
| 4C40605 |   0 |1ED9  D0FC| 192.168.37.103  141.207.183.233|UDP| 4500  4500 | 19481    | 7684    21474   | ALLOW | 2  3  1  3 | -1 -1 |  -1  |    Xfinity Mobile       |21474 7684  | 1|0 | eth1   wlan34
(Edited)
Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes
Is this command available on Unleashed or am I doing something wrong?
ruckus# get rflow
The command is either unrecognized or incomplete. To view a list of commands that you can run  from this context, type '?' or 'help'.
(Edited)
Photo of Andrew Giancola

Andrew Giancola

  • 233 Posts
  • 72 Reply Likes
Back out of 'get' and hit tab, or question mark(?). I don't have "get" commands on my system. I have "Show".
Photo of Andrew Giancola

Andrew Giancola

  • 233 Posts
  • 72 Reply Likes
OOOH
Daniel, tab back and type in 'ap-mode'. you'll get the correct CLI for the AP.
Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes
That works ;) !
Photo of Tony Heung

Tony Heung, Official Rep

  • 57 Posts
  • 14 Reply Likes
Sorry guys, I thought it's something everyone would know.  :-)

Reference below:

https://docs.arris.com/bundle/unleashed-200.9-commandref/page/GUID-98BB49DE-3E1E-48F9-BDAF-764A42BEE...

To access the AP CLI from the Unleashed Master (controller) CLI, use the following command: 

ap-mode

ruckus# ap-mode
You have all rights in this mode.
ruckus(ap-mode)#

Photo of Daniel M

Daniel M

  • 64 Posts
  • 13 Reply Likes

Thank you again Tony!

I was able to connect to the relevant member AP and see the following in real-time:

rkscli: get rflow
| flag | age | MAC1  MAC2 | IP1                 IP2      | proto|PORT1 PORT2 | flow ID | 1tx  1rx | Deny |     QoS    |  R/L |    URL    |         APP         | 2tx  2rx  | retry | UTP  | ifname
...
| 4C0060D |   0 |9D9E  1EDA| 208.54.37.80  198.51.100.200|UDP| 4500 42670 | 25808    | 22800    2528   | ALLOW | 2  3  1  3 | -1 -1 |  -1  |      T-Mobile       |2528 22800  | 3|0 | wlan34   eth0

We look good ;) !
(Edited)
Photo of Raymond Lau

Raymond Lau

  • 6 Posts
  • 1 Reply Like
For Verizon, I believe the correct edpg dns is wo.vzwwo.com. At least that works for me. I got it via watching traffic with tcpdump and also found it referenced on a competitor's wifi calling setup kb.