What is the minimum standalone firmware version to connect AP to vSZ

  • 1
  • Question
  • Updated 5 months ago
  • Answered
How can I find minimum AP standalone Firmware version required to connect AP to vSZ 5.1
Photo of gpmpa

gpmpa

  • 76 Posts
  • 4 Reply Likes

Posted 5 months ago

  • 1
Photo of Albert Pierson

Albert Pierson, Employee

  • 132 Posts
  • 114 Reply Likes
Hi gpma

Starting with AP standalone version 104.x the process that allows AP to directly connect to an SZ was included (wsgclient) so you only need to use the set scg ip <control_ip> command to connect to any SZ platform.

Prior standalone versions of code only had the ZD control program (apmgr) and you needed to enable the LWAPP2SCG program in the SZ which allowed the SZ to act as a Zone Director for the purpose of allowing standalone or ZD based AP's to connect to the SZ and get loaded with an SZ version of code.

You can find the version of code for any given model AP on the support site:

https://support.ruckuswireless.com/software

Here is a KBA article that describes the different AP firmware versions:

Master KBA: All about AP firmware - Standalone, ZD, or vSCG/SCG/SZ managed 

This is a collection of articles on how to configure Access Points for any use.
https://support.ruckuswireless.com/articles/000004555


I hope this answers your question,

Thanks for choosing Ruckus Networks - a Commscope company.



Photo of gpmpa

gpmpa

  • 76 Posts
  • 4 Reply Likes
Hey Albert,
Thanks for the detailed response.
I have SZ version 5.1.x and AP with fw 101.x.
When I try to connect AP to controller, it goes offline shortly after connected to SZ. Logs show fw update failure.
Hope this shouldnaolved by fw upgrade to 104.x. any thoughts?

Thanks
Photo of Albert Pierson

Albert Pierson, Employee

  • 132 Posts
  • 114 Reply Likes
Hi gpmpa,

Yes - if you upgrade the AP's to AP standalone version 104.x or 106.x then the AP's should be able to connect to the SZ's and get upgraded to the AP image configured in the SZ zone.

The AP requires to "discover" the SZ using set scg ip or by having DHCP option 43, DNS or AP registrar configure the AP with the SZ's control IP.

One possible issue you may be running into is the signed AP firmware issue.  Starting with SZ version 3.6 AP's can only accept images that are signed by Ruckus certificate - this is to prevent a malicious version of AP code to get loaded.  Standalone version 101.x was unsigned and can not upgrade to the Fully Signed image in SZ 5.1.x. Standalone version 104 is a "bridge" version that has ISI (Intermediate signed image) that can allow unsigned image AP's connect to a fully signed image.

Details of this can be found in KBA article:

AP Image Signing: Unable to upgrade APs running UI (unsigned image) version of firmware to FSI (fully signed) version of firmware 

A new certificate security mechanism implemented by Ruckus to prevent installing hacked or modified firmware into Access Points requires upgrading APs running older versions of code to first upgrade to an intermediate version of code before they can be upgraded to the latest fully secure versions...
https://support.ruckuswireless.com/articles/000008727


I hope this solves your issue.

Cheers

Albert