vSCG with R300 Zoneflex Error Code 307 - AP Heartbeat Lost

  • 2
  • Question
  • Updated 2 years ago
  • Answered
Hey all,
i'm new here and i have this problem, maybe someone can help.

we have vSCG 2.5 and we wait for the new version, up till now we have 92 R300 Zoneflex in different locations and they all behind NAT.
all the zones configured for Tunnel type GRE.
and it's all works great, but every now and then (approximately 7-10 time a day .per Zoneflex) i receive this outstanding alarm code 307 AP heartbeat lost.

any suggestions?

thanks in advance,
Moran Barashi.
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like

Posted 3 years ago

  • 2
Photo of Gomathi Shankar

Gomathi Shankar, Official Rep

  • 9 Posts
  • 1 Reply Like
Hi Moran,

This alarm occurs when the AP heartbeat is lost. AP's sends out heartbeat messages (also called as Keepalives) to vSCG at a regular interval.

If a heartbeat message is not received at the vSCG for a certain period, it will raise a “heartbeats lost” alarm.

If there is a consecutive heartbeat lost messages for a defined period, then the vSCG will raise a “Lost contact to AP” alarm and show the AP as Disconnected.

The issue here is sometimes the heartbeat messages from the AP's are not reaching the vSCG, this is possible since the AP's are placed on different locations and behind NAT and has to communicate with vSCG over the internet.
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
Thank you Gomathi for the response,

do you thing that if i change the interval for the heartbeat or the the timeout for it, it will stop?

and if so, where do i config thous settings?
(found the interval only on the access point configurations)

thanks,
Moran Barashi
Photo of Gomathi Shankar

Gomathi Shankar, Official Rep

  • 9 Posts
  • 1 Reply Like
Moran, it is not recommended to change these intervals. If this continues, I would suggest checking the packet drop rate (if possible) on the edge routers, where the vSCG & AP's are connected.
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
Thanks Gomathi,
i'll look for that.


if i may, another question, i noticed that some of the errors occur 2 hours later then the current time, and i saw in the Configuration>>vSCG System>>System Time
that SCG System Time is 2 hours later, but the SCG System UTC Time is current time.
when i log in the vSCG and run "show clock" it's the correct time.

what is that mean?!
and where do i change that "SCG System Time"?
(i use NTP : time.nist.gov, and it's updating.)

thank you very much,
Moran
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
so, there are no package lost [had 15,000 pings from the router at site to the controller], tomorrow we'll check the connectivity from the AP to the router and the controller.
(the sites are not available to me right now.)

any idea about the time configurations?
in the manual there is just one line with the "SCG System Time" but i have another line...
hummm...

well,
thanks for all the above replies.
Moran Barashi.
Photo of Gomathi Shankar

Gomathi Shankar, Official Rep

  • 9 Posts
  • 1 Reply Like
SCG system time shows what has been selected for the SCG System time zone. This can be edited from vSCG GUI under Configuration>>vSCG System>>System Time.

SCG system UTC time will show the time in UTC and cannot be edited.

When typing the command "show clock" it displays the output of SCG system UTC time.
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
thanks for the reply, the time zone was set to out country GMT +2 and when i changed it to +0 it got the correct time.
wired..

well, thank you very much for every thing.
i'll check the connectivity from the Zoneflex to the Controller and hope that will solve the problem.

best regards
Moran Barashi.

Photo of Gomathi Shankar

Gomathi Shankar, Official Rep

  • 9 Posts
  • 1 Reply Like
Thanks for the update, Moran. Report to us if the time gets changed.
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
hey Guys,

we did some research and several tests,
first of all, now when the time on the "SCG System Time" is synchronized and both System and UTC Time are correct i still get heartbeat lost that occur two hours from the current time...
i don't think it's the controller, but where can it coming from?!

the other thing with the the heartbeat problem we have, we tried ping the controller using a cable connected computer instead of the Zoneflex R300 and ping was stable for 2000 pings, from the router we pinged 15000 with no errors..
but when the computer was connected to the Zoneflex via wifi we have had some request time out...

the only thing i can think about, is to have a greater period of time before timing out and flag heartbeat lost.

do you have any other idea?

thanks in advance,
Moran Barashi
Photo of Gomathi Shankar

Gomathi Shankar, Official Rep

  • 9 Posts
  • 1 Reply Like
Moran,

I would say, we should not compare the ping results between a pc connected wired & wireless, there are lot of difference in the way they get access to the medium to send the data.

Moreover the heartbeat is originated from the AP, so doing a ping test from a client behind the AP is different.

Regarding the incorrect time for the heartbeat alarm, this needs some more data, to find the root cause of this. Could you please go ahead and open a support case, so that we can provide you the steps to collect the required data in finding the reason for this issue.
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
O.k.
Thank you very much.
I'll do that first thing tomorrow morning.

It was a pleasure.
Moran Barashi
Photo of Daniel Svanberg

Daniel Svanberg

  • 2 Posts
  • 0 Reply Likes
I have the same problems with multi R300. Could you guys post the answer here?
Photo of Gomathi Shankar

Gomathi Shankar, Official Rep

  • 9 Posts
  • 1 Reply Like
Daniel, the reason for this error message has been explained on this thread, but the root cause may be different and depends on the network setup.

To find the root cause, we require certain data from your network. Please could you open a support case, so we can provide you the steps to collect the required data.
Photo of Paddy Naughton

Paddy Naughton

  • 9 Posts
  • 0 Reply Likes
Hello Moran, Did you get to the bottom of this problem at all? We are experiencing something very similar where a high number of heartbeat lost events are showing on 4 APs on one customer. It would be good to know what you found to be the cause.  
Photo of Moran Barashi

Moran Barashi

  • 8 Posts
  • 1 Reply Like
Hello Paddy, this days i can see allot of 314 Events (heartbeat lost). we have a known problem with the IPVPN Connection between the sites (the R300 on Several Sites and the vSCG on another one).
as i see it, we have 2 options.
Option #1 : increase the time to wait for reply.
Option #2 : upgrade our IPVPN Connection.
we are choose the Second Option, it's just take some time (Municipality work very slow..)

i don't know if it's the same problem we have, what is the architecture on you'r customer's network?
Photo of Shahzad Ashraf

Shahzad Ashraf

  • 1 Post
  • 0 Reply Likes
"Your Support service expires in [32] days. " Showing on front panel on ZD interface...
what is this message stand for..