VLAN Configuration question for wireless network

  • 1
  • Question
  • Updated 4 years ago
Hi all,

This is my setup.

HP Procurve 2530 SWITCH on 192.168.1.2

2x VLANs
User VLAN: 20
Public VLAN: 30

Ruckus ZD1100 controller with 6x 7363 Access points with 2x SSIDs one for each VLAN.

Ports on the switch
1-10 tagged (ZD100 wireless controller and 6x 7363 access points are plugged in here with static addresses from 192.168.1.11 to 17

11-40 Untagged VLAN 20 – user router plugged in with DHCP 192.168.1.x

41-48 Untagged VLAN30 – public router plugged in with DHCP 192.168.2.x

When testing, i cannot connect wirelessly to the user SSID, doesnt get an address from DHCP. This configuration doesnt appear to work, what am I doing wrong?

If I place all the wireless kit on VLAN10 it will probably work fine, but I have been told to set it up as above.
Photo of Unrealone1

Unrealone1

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2114 Posts
  • 297 Reply Likes
VLANs 20 and 30 need to be tagged, and there needs to be DHCP and a def-gw router for each.
Photo of Jeff Roback

Jeff Roback

  • 25 Posts
  • 8 Reply Likes
your issue is that the 2530 procurve isn't a layer 3 switch, so it can't route traffic between these vlans. "The HP 2530 Switch Series consists of 12 fully managed Layer 2 edge switches" So while this switch supports putting traffic on different vlans, it doesn't support moving traffic between them. So you need either a router (not recommended but will work) or a layer 3 switch to handle that for you.