using portfwd on Ruckus 7363

  • 1
  • Question
  • Updated 3 years ago
I'm trying to use portfwd from the command line to forward ports on my Ruckus 7363. However, I can't seem to make a new rule. The prompt just keeps telling me the rule doesn't exist.

rkscli: set portfwd test-rule 2200 2200 both 192.168.50.42 2200 enable
the rule 'test-rule' does not exist

The help for this utility doesn't provide any information for creating a new rule:

rkscli: help portfwd
get portfwd : get portfwd
-- Display configured port forwarding rules
set portfwd : set portfwd {options}
-> {tcp|udp|both}
-> {enable|disable|delete}
-- Configure a port forwarding rule

The help mentions an optional argument {options} but none of the options are listed. Can I get help using the utility or port forwarding on this router in general?

For reference, here is my output from get version:
Ruckus 7363 Multimedia Hotzone Wireless AP
Version: 9.4.3.0.12
Photo of scott r

scott r

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of scott r

scott r

  • 3 Posts
  • 0 Reply Likes
I just upgraded to the most recent firmware version for this device. Not getting the same error anymore, but it still doesn't seem to be working.

rkscli: get version
Ruckus 7363 Multimedia Hotzone Wireless AP
Version: 9.6.1.0.15
OK
rkscli: set portfwd bender-ssh 2200 2200 tcp 192.168.50.42 2200 enable
+ /etc/init.d/nat portFw_enable br0
+ /etc/init.d/nat hotspot br0 10.1.0.1
OK
rkscli: get portfwd
Currently configured port fwd rules
OK

The rule still isn't showing up.. Is there something I'm doing wrong or is this a bug?
Photo of scott r

scott r

  • 3 Posts
  • 0 Reply Likes
Still trying... Realized I might have been using the command wrong. Even tried rebooting. Still no luck. =[

rkscli: set portfwd bender-ssh 2200 2200 tcp 192.168.50.42 2200
+ /etc/init.d/nat portFw_enable br0
+ /etc/init.d/nat hotspot br0 10.1.0.1
OK
rkscli: set portfwd bender-ssh enable
+ /etc/init.d/nat portFw_enable br0
+ /etc/init.d/nat hotspot br0 10.1.0.1
OK
rkscli: reboot now
OK

rkscli: get portfwd
Currently configured port fwd rules
OK
Photo of Keith - Pack Leader

Keith - Pack Leader

  • 860 Posts
  • 50 Reply Likes
Technically...we don't support the CLI on standalone APs. That said, I *think* you might be using a deprecated command. Try using set/get interface instead.

get interface []
set interface [forward ] type untag {|none}
[vlans ]
Photo of Tee Chong Lee

Tee Chong Lee

  • 1 Post
  • 0 Reply Likes
hi keith,

how do i use the set interface cli to set port forwarding to an internal IP at a specified port? I can't figure out from the syntax given in the cli guide.