Uplink ports explained

  • 1
  • Question
  • Updated 3 months ago
  • Acknowledged
Hello,

So sorry for what could be a very basic question but I'm starting to learn about networking and Ruckus.

I've got an ICX 7150 24P switch where I have configured 2 vlans: (1st vlan: 1/1/1 to 1/1/12 and 2nd: 1/1/13 to 1/1/24). I would like to connect this my core switch which also has these 2 vlans.

Could I use the uplink ports? if so, should I have one cable for each vlan or how does this work?

Thank you!
Photo of Fernando Flórez

Fernando Flórez

  • 22 Posts
  • 6 Reply Likes

Posted 3 months ago

  • 1
Photo of chill

chill

  • 18 Posts
  • 7 Reply Likes
I believe the 7150-24P has ports like 1/2/1-1/2/8, right? You can use these as your trunking ports.

To do this, tag both vlans on the port you want to use, for example 1/2/1. Both vlans can be tagged across one port, then you only need one cable to uplink to another switch.

Or if you want to lag, you can use 1/2/1 and 1/2/2, or more. Then you would need more cables but the vlans would still be tagged across all ports.
Photo of Ben

Ben, Employee

  • 52 Posts
  • 9 Reply Likes
Hey Fernando, 

You can pass multiple vlans on one port. For example you could pass your two example vlans upstream with something like this:

enable
conf t
vlan <vlan-1> <vlan-2> *not sure on your numbers*
tagged eth 1/2/1 

This would allow you to pass both vlans' traffic upstream to your core on one port. Your core switch would also need the appropriate vlans 802.1q tagged towards the 7150. 
Photo of NETWizz

NETWizz

  • 47 Posts
  • 15 Reply Likes
vlan 123 name DATA by port
untagged ethe 1/1/1 to 1/1/12
tagged ethe 1/2/1
!
vlan 567 name MOREDATA by port
untagged etthe 1/1/13 to 1/1/24
tagged ethe 1/2/1
!


Connect 1/2/1 to your core.

Your core MUST also have the port you connect TAGGED in the same vlan(s).

If your core is not Brocade the terminology is that it would be called a TRUNK interface.

Something like:


interface GigabitEthernet1/1/1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 123,567
switchport mode trunk
!


Photo of Fernando Flórez

Fernando Flórez

  • 22 Posts
  • 6 Reply Likes
Thank you!
Photo of Fernando Flórez

Fernando Flórez

  • 22 Posts
  • 6 Reply Likes
Hello,

Sorry for getting back to this but I've tried a couple of things and they don't seem to work as expected. Here is my scenario:

2 VLANs:

vlan 1: 1/1/1 to 1/1/12 untagged
vlan 2: 1/1/13 to 1/1/24 untagged

What I would like to do is use both uplink ports to increase bandwidth and also to assure availability in case of the cables fail.

LAG creation:

lag myuplink dynamic id auto
ports ethernet 1/2/1 to 1/2/2

Is that all? Cause doesn't seem to work.

Thank you!
Photo of chill

chill

  • 18 Posts
  • 7 Reply Likes
What firmware version are you running? LAG creation will differ a little bit between versions. 

One thing for certain, you will need to tag the uplink interface on both vlans.

For example:

conf t
vlan 1 2
tag e 1/2/1

This will tag both vlans on your uplink interface. If you are lagging the uplink between 1/2/1 and 1/2/2, you will only need to tag the primary port of the LAG (1/2/1). 
(Edited)
Photo of Fernando Flórez

Fernando Flórez

  • 22 Posts
  • 6 Reply Likes
My current firmware is: 8.0.80

So this should do it?

lag myuplink dynamic id auto
ports ethernet 1/2/1 to 1/2/2

vlan 1
untagged ethernet 1/1/1 to 1/1/12
tagged ethernet 1/2/1 to 1/2/2

vlan 2
untagged ethernet 1/1/13 to 1/1/24
tagged ethernet 1/2/1 to 1/2/2



Whats the difference or in which cases should I use a static or dynamic lag?

Thank you!
Photo of chill

chill

  • 18 Posts
  • 7 Reply Likes
Static or dynamic depends on the other switch's capabilities. Dynamic is the better option. If it's another Ruckus, go dynamic for sure. Check to make sure that the LAG is active with "show lag". Both links should be in forwarding state.

Otherwise, your vlan config looks correct. 
Photo of NETWizz

NETWizz

  • 47 Posts
  • 15 Reply Likes
If you did it correctly, it should remove 1/2/1 and 1/2/2 from the VLANS and add lag1 as a lag interface.

Having multiple VLANs you would need to do "tagged lag 1" in both VLANS to carry them both across the LAG Trunk.

In 08.0.80 you should not need to set the primary-port or use the keyword deployed, but you can verify with "show lag"
Photo of Fernando Flórez

Fernando Flórez

  • 22 Posts
  • 6 Reply Likes
Doesn't seem to work unfortunately. I'm trying to connect this switch to a fortinet fw.

Here is my new test conf:

lag fw dynamic id 1
ports ethernet 1/2/1 to 1/2/2

vlan 3 name test
tagged ethernet 1/1/1 to 1/1/24 lag 1


With the cable connected to the uplink I don't received an ip (the firewall has a dhcp service as a test).

If I connect the ethernet on one of the downlink ports I get an IP of the default lan (not vlan). If I create a vlan conf on my laptop then I received the ip from the vlan correctly.

Also, when I do a show lag I get that both uplink ports are in "blocked" state.

What I'm doing wrong?

Thanks!
Photo of chill

chill

  • 18 Posts
  • 7 Reply Likes
At this point I would look to simplify the situation and disable the lag on both ends. Make sure you can get communications working over a single link, and then get the lag configured after that
Photo of Fernando Flórez

Fernando Flórez

  • 22 Posts
  • 6 Reply Likes
Changing my lag setup to static made it work!

Thanks a lot guys!