Unsupported AP Models

  • 1
  • Question
  • Updated 9 months ago
  • Acknowledged
Hi everybody,

This may seem like a silly question, but I would just like confirmation of my assumption.

We have our production vSZ-H still running on 3.6.x.x. We are looking to upgrade to 5.1.2 to get some of the ICX switch management features available to us.

I've been through the release notes and the only thing of major concern is that the R300 AP's are on the list of 'Unsupported AP Models', and we have some of these out in the wild.

I would assume that if we upgrade, these AP's will simply no longer be able to connect to our vSZ and become unusable, but I can't find anything that tells me exactly that.  And with the newer version still being able to support the older 3.6 AP firmware versions, there is a small part of me that wants clarification the R300's will 100% just stop working if we upgrade? 

That's fine if that's what will happen, it gives me a business case to go back with to get these AP's upgraded, I just need to be sure.

Thanks,
Chris.
Photo of Chris Grace

Chris Grace

  • 13 Posts
  • 1 Reply Like

Posted 9 months ago

  • 1
Photo of Abi

Abi

  • 120 Posts
  • 59 Reply Likes
Hi Chris,

Please check the relase notes and follow supported upgrade paths, then once upgraded the Zones don't upgrade unless you upgrade them, upgrading vSZ to 5.1.2 supports upto three previous major builds.

Please check the below document,
https://support.ruckuswireless.com/do...

Regards,
Abilash PR.
Photo of Niko Mattheus

Niko Mattheus

  • 7 Posts
  • 7 Reply Likes
Hi Chris, 

there is no problem  on the moment. We had a similar situation overhere, we're running vsz-hs 5.1.x upgraded from 3.6.x.
you can safely upgrade to 5.1.x. after that is finished, you have to manual upgrade each zone where it's possible.
you can do this safely, when there is a unsupported model in the zone you get a warning and the upgrade of the zone is stopped

Niko
Photo of Chris Grace

Chris Grace

  • 13 Posts
  • 1 Reply Like
Thanks Niko,

So you upgraded from 3.6.x to 5.1.x with some AP's that were on the unsupported AP list, and they continue to work on 5.1.x quite happily as the zone is still on the 3.6.x AP firmware?

Just want to be sure about this before I look at any kind if upgrade, we're talking ~100 access points that I can't afford to kill!

Cheers,
Chris.
Photo of John D

John D, AlphaDog

  • 579 Posts
  • 179 Reply Likes
This is correct, upgrading the controller does not automatically upgrade a zone. In fact a zone containing unsupported APs will refuse to let you upgrade the zone until unsupported APs are moved out. You can create multiple zones, one for your older APs and one for your newer ones, if you want to take advantage of new features.

Just note that if you ever have to clean install your controller again, you have to follow a similar upgrade path and can’t just start with 5.1.1 or later. The only way to get the option to use v3.6.x is to have previously been on 3.6 and upgraded to a newer version.
Photo of FrancisA

FrancisA

  • 17 Posts
  • 6 Reply Likes
We have a similar situation.  VSZ is already on 5.1.1, but our production zone is on 3.6.2 because we still have around 50 7372 APs.  

We plan to buy new R320s (to also gradually replace 7372s), but we're unsure if those will work on 3.6.2. 

If we have create a 5.1.1 zone with identical WLANs as the 3.6.2 zone within the same location, what impact will it have?  Will it affect roaming?  What about channel assignments?  I assume we'll need to always generate identical guest passes on each zone too.  
Photo of Albert Pierson

Albert Pierson, Employee

  • 173 Posts
  • 149 Reply Likes
Hi John,
Grace period - the ability to disconnect or roam between AP's without having to re authenticate is NOT passed when AP's are not in the same zone .. so seamless captive portal based roaming does not work between zones, devices will have to re-authenticate.

The SZ supports n-2 AP firmware versions.  5.1 support 3.6 (5.1, 5.0, 3.6).  5.2 will not support AP's running 3.6 and the upgrade will give you an error if there are any unsupported (3.6) zones.  Also you cannot create new 3.6 (or 5.0) zones after upgrading to 5.1.  If you think you will need new AP Zones running older versions you need to have these zones created before upgrading.

I hope this information is helpful

Thanks

Photo of Edith Laird

Edith Laird, Employee

  • 1 Post
  • 0 Reply Likes
Chris, the R500 is supported on 5.1.2.  In the 5.1.2 GA release notes it is listed as a supported AP. 

Can you point me to the document you are referencing that lists it as an unsupported AP?

While the R500 did go EOS on April 30, 2019, we will still have active SW development for at least one year after the EOS date (through April 30, 2020).

Edith Laird
Ruckus AP PLM


Photo of Chris Grace

Chris Grace

  • 13 Posts
  • 1 Reply Like
Hi Edith,

It is the R300, not the R500 that I am referring to.

Thanks,
Chris.
Photo of Javier Valdes

Javier Valdes

  • 24 Posts
  • 10 Reply Likes
Guys, thanks for clarifying this. It has been very informative also for me. I was one the guys that thought that wasn't possible to upgrade from 3.6 to 5.1 because the loss of some old APs. I didn't know that SZ can handle up to three older versions.
One question here, is it possible to upgrade from 3.6 to 5.2 and have some old APs in a zone with 3.6?
I'm not sure if this "three previous major builds support" starts with 3.6 itself for example 3.6, 5.0 and 5.1 or starts with the next version like, 5.0, 5.1 and 5.2.

UPDATE: Forget it, I didn't notice that in Albert Pierson's post already clarify this.

Best regards,
(Edited)