Unleashed configure smart-roam

  • 1
  • Question
  • Updated 1 week ago
I would like to configure smart-roam on my Unleashed network. However, I cannot access the correct WLAN as de CLI does not recognize my SSSID.
I have a WLAN with ID 1 and "NAME = Simply Better Wireless" (yes, really). If i enter the following command:

ruckus#(config) wlan simply better wireless
The command is either unrecognized or incomplete. To view a list of commands that you can run  from this context, type '' or 'help'.

It will not respond; sometime it creates a new WLAN and not load my current one. Therefor I cannot enable smart-roam. Why is that and what is the correct command? I've tried anything with or without quotes but nothing helps. Please advice.
Photo of Rob Harmsen

Rob Harmsen

  • 3 Posts
  • 0 Reply Likes

Posted 1 week ago

  • 1
Photo of Andrew Giancola

Andrew Giancola

  • 238 Posts
  • 74 Reply Likes
try 'get wlan-list' what does it show you?
Photo of Rob Harmsen

Rob Harmsen

  • 2 Posts
  • 0 Reply Likes
Hi Andrew,
this command is not recognized;

ruckus# get wlan-list
The command is either unrecognized or incomplete. To view a list of commands that you can run  from this context, type '?' or 'help'.

ruckus# config
You have all rights in this mode.
ruckus(config)# get wlan-list
The command is either unrecognized or incomplete. To view a list of commands that you can run  from this context, type '?' or 'help'.

Photo of Sanjay Kumar

Sanjay Kumar, Employee

  • 259 Posts
  • 83 Reply Likes
Hi Rob,

May I know the Unleashed version the APs are running on?

Are you able to see the SSID config using the command "Show config"
If yes, then try setting the smart roam from the "ap-mode" as below

ap-mode
get wlanlist

(identify the wlan number of the SSID and set the smart roam accordingly)

get roam_factor wlanX
set roam_factor wlanX 3
Photo of Sanjay Kumar

Sanjay Kumar, Employee

  • 259 Posts
  • 83 Reply Likes
Below is the KB article which has the information on setting the Smart roam on the AP CLI.
https://support.ruckuswireless.com/articles/000002277
Photo of Rob Harmsen

Rob Harmsen

  • 3 Posts
  • 0 Reply Likes
Hi Sanjay,

I use Unleashed version 200.9.10.4.202 on both Access Points (R510 master, R320 slave).

The "ap-mode" and other commands from you worked to set the roaming factor from 1 to 3. 
But when I type "show wlan all" directly from the prompt, teh status of the WLAN's is still unchanged:

SmartRoam = Disabled  Roam-factor = 1

Please advice.
Photo of Sanjay Kumar

Sanjay Kumar, Employee

  • 259 Posts
  • 83 Reply Likes
Hi Rob,

Try using the command set roam_enable <wlan number> enable.
(Eg : set roam_enable wlan33 enable)
To verify if the smart roan is enabled or not use the command "get roam_enable wlan33"
Photo of Sanjay Kumar

Sanjay Kumar, Employee

  • 259 Posts
  • 83 Reply Likes
The command "ruckus(config)# wlan simply better wireless" should work, I wonder why it is not working.