Unable to upgrade my ZD1100

  • 1
  • Question
  • Updated 5 months ago
  • Answered
Hi!
I have a ZD1100 with  firmware 9.6.1.0.15 and Two AP zf7372.
Today, it's really hard to connect the Administration because updated web browser block website using RC4. So I have decided upgrade my ZD.
I saw that it wasn't possible to upgrade directly to 9.10.x, so I have started with firmware 9.8.3.0.44.
I get the page "Upgrading 0%" then... nothing. After 1 hour nothing changed, so I have restarted ZD box.
When restarted, I can access to my administration interface, I'm still in 9.6.1.0.15, but my two access point can't contact the ZD (I have message "Model[zf7372] is not supported"). But acording this ticket (and because it was working before the upgrade), it should be supported!
Anyway, I have tried to upgrade my ZD with firmware 9.8.1.0.101, 9.6.1.0.15, I have always the same problem.
Pluggin a console cable, here is the output when starting an upgrade:
grep: /etc/airespider/authsvr-list.xml: No such file or directory
tar used greatest stack depth: 12552 bytes left
lwapp_release: proto=2, refcnt=2
lwapp_sock_destruct: refcnt=0
lwapp_release: done proto=2, refcnt=0
lwapp_release: proto=1, refcnt=2
lwapp_sock_destruct: refcnt=0
lwapp_release: done proto=1, refcnt=0
br0: port 3(vif0) entering disabled state (ifconfig,1974)
device vif0 left promiscuous mode
br0: port 3(vif0) entering disabled state (brctl,1975)
br0: port 4(uif0) entering disabled state (ifconfig,1976)
device uif0 left promiscuous mode
br0: port 4(uif0) entering disabled state (brctl,1977)
NET: Unregistered protocol family 30
Exiting
Stop netlink server
So, here are my question:
- Did I do something wrong?
- What can block the ZD upgrade?
- What can I do to establish the connection between my AP and my ZD?

Thanks for your help!
Photo of SGR

SGR

  • 3 Posts
  • 1 Reply Like
  • anxious

Posted 8 months ago

  • 1
Photo of SGR

SGR

  • 3 Posts
  • 1 Reply Like
Finally solved my issue upgrading the firmware through CLI! :D
Photo of Mitchell Axtell

Mitchell Axtell

  • 56 Posts
  • 14 Reply Likes
I know your exact symptoms.  Did you use Internet Explorer (9+) because Firefox/Chrome wouldn't allow it?  If so, you have to add the website to the "Compatibility View" list in order for the script to function.  Either that, or get ahold of an older version of Firefox that will allow you to manage it.
Photo of SGR

SGR

  • 3 Posts
  • 1 Reply Like
You are probably right, I was using IE 9 because my chrome and Firefox were up to date, so not working on the old version.
Photo of Jeff Bingham

Jeff Bingham

  • 5 Posts
  • 0 Reply Likes
 I recently had this issue and Support had me download Firefox 45 and then surf to about:config, search for and change security.tls.unrestricted_rc4_fallback to user mode. I just clicked on it once to change it and then I saved the settings and performed the upgrade and it actually worked slowly but surely. I went directly from 9.6.1 to 9.8.3.0.44