Unable to see devices via Bonjour using ZF7942

  • 1
  • Question
  • Updated 3 years ago
I'm using two ZF 7942 APs to provide wifi in a small office - they're each connected directly to the office's network switch and pass on DHCP requests to our Active Directory box.

Everything works fine EXCEPT for one very odd thing: wifi clients are unable to discover network devices using Bonjour. This is most glaring when trying to add printers. Plugging the client in to an Ethernet cable corrects the issue.

Any idea how/why the Bonjour protocol is getting blocked (presumably) by the ZF 7942s?
Photo of AgencyPJA

AgencyPJA

  • 8 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 137 Reply Likes
First, what firmware are you running? Ruckus fairly recently made some changes (circa 9.7 if I remember correctly) that increases the QoS level of bonjour packets, which reportedly helped a ton.

On top of that, some have found it helpful to disable directed multicast and IGMP/MLD snooping. This Ruckus article describes the process from the view of a zonedirector, but most of these commands have 1:1 mappings to standalone CLI commands if you are running Standalone.

https://support.ruckuswireless.com/answers/000001910



It's worth noting that I've never found it necessary on 9.8 and newer firmware to apply these custom settings -- Bonjour seems to be routed reliably out-of-the-box for my network config.
(Edited)
Photo of AgencyPJA

AgencyPJA

  • 8 Posts
  • 0 Reply Likes
John:

You nailed it - upgrading from 9.4.whatever-it-was to 9.7 resolved the issue. Thanks!