Unable to add access point to zonedirector (zf7352 to zd1100)

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Hi 
I'm really struggling with adding a new Z7352  to our wireless network (z1100 9.7.2.0 build 9).  The zonedirector just does not see it (or provision it).

I've hard reset the access point, I've updated the firmware to 9.7.2.0.9 (which our zd1100 specifically says it supports on this AP).  I've given it a static IP on our range, I've plugged it directly into the zone director, I've checked we still have licences available but the problem still persists.

Any ideas very welcome.
Photo of dave wilson

dave wilson

  • 3 Posts
  • 0 Reply Likes
  • sad

Posted 2 years ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 1982 Posts
  • 276 Reply Likes
Usually a hard reset and the AP on the same network will get your AP discovered, but you state that you're using static IPs instead of DHCP.  You might therefore need to tell your AP the ZD's IP
address with a CLI 'set director ip a.b.c.d' and 'reboot'.  When the AP comes back, it should send
LWAPP to your ZoneDirector.  Be sure your ZD's AP policies auto-approve AP join requests.
Photo of Eizens Putnins

Eizens Putnins

  • 107 Posts
  • 42 Reply Likes
Agree with Michel -- this must solve your problem. reason of your problem is that,  I think from version 9.6, the  discovery mode was changed, and AP can't be discovered without using DHCP server even on same subnet. So connect by SSH to AP (using default username and password after factory reset) and use command "set director ip  xxx.xxx.xxx.xxx, as  Michel suggested.
Photo of dave wilson

dave wilson

  • 3 Posts
  • 0 Reply Likes
Hi ,

Thanks for your replies


Sorry I wasn't clear, I set the IP address of the Ruckus AP to a static one as a troubleshooting measure after a factory reset failed previously.  We do have DHCP in operation .

I haven't tried specifying the zonedirector IP to the access point.  Is that option  available in the web interface?
Photo of Eizens Putnins

Eizens Putnins

  • 107 Posts
  • 42 Reply Likes

Option is available in GUI only in the latest software (9.9, 9.10), otherwise you need to use SSH. Which is actually pretty streightforward. Log in, send the command, reboot.

I have seen couple times this kind of problems exactly with 9.7.2, probably there may be a bug with discovery. Anyway, set director IP works always... Also probably you want to upgrade ZD to later version (if you don't have legacy APs).

Photo of dave wilson

dave wilson

  • 3 Posts
  • 0 Reply Likes
'set director ip' did the trick.  Thanks very much all
Photo of Michael Brado

Michael Brado, Official Rep

  • 1982 Posts
  • 276 Reply Likes
Well... since you have DHCP to provide IP to your access points, what kind of DHCP server is it?

We have knowledge base articles describing how to configure Option 43 with your ZD's IP address
to help provision your new APs, if you are looking to add more.

If you're logged into our Support site, here is a search of 'dhcp option 43' under Knowledge. 

https://support.ruckuswireless.com/answers/search?article_id=&query=dhcp+option+43
Photo of Eizens Putnins

Eizens Putnins

  • 107 Posts
  • 42 Reply Likes
If you have APs and ZD in the same subnet, you normally don't need to bother with DHCP option 43 -- discovey works without any additional efforts. When you really need DHCP option 43 is any big network with APs in different VLANs. Than you really want to add option 43 to every scope which can supply IPs to APs, which is often easier than to configure DNS entry with director name.
(Edited)