TP-Link TL-WR902AC in Client mode not connecting to SZ100 R500 APs

  • 1
  • Question
  • Updated 3 years ago
  • Acknowledged
we want to use a TP-Link TL-WR902AC Wireless Travel Router setup in Client-Mode connecting to our Ruckus WiFi Infrastruktur (SZ100 with R500 APs) getting a wired Copy-Device wireless.

I can scan the Wifi-Networks on the TP-Link client and the networks are available, but it is not connecting. There are also no entries in SZ100 Log shown where any connection attempt of the client are made

AP Firmware:

Any hints, or other people who tried a similiar setup?


Photo of RedVision81


  • 31 Posts
  • 6 Reply Likes

Posted 3 years ago

  • 1
Photo of Todd


  • 65 Posts
  • 17 Reply Likes
I do this exact thing with a few of the TP-Link TL-WR710N.  Works well.  No issues... At all surprisingly.  ZF7982's with ZD1200 (
Photo of RedVision81


  • 28 Posts
  • 6 Reply Likes
Now i tried two different TP-Link Routers, with no luck. i dont get any connetion to the wi-fi network. 

in the TP-Link forum someone told me that the AccessPoint/Router where you want to connect to needs DHCP enabled, without it will not be possible.

how did you managed this?
Photo of RedVision81


  • 31 Posts
  • 6 Reply Likes
Thanks Todd, i will Update the AP Firmware tomorrow on my SZ100 and try to do further tests. or maybe i am going to buy the TL-WR710N for testing.
Photo of Michael Brado

Michael Brado, Official Rep

  • 3298 Posts
  • 523 Reply Likes
The issue is related to WDS ( and Ruckus developed
proprietary 4 MAC address frame format in our early IPtv AP/CPEs, that is supported on all ZD managed APs,
and may or may not work quite the same under SZ controller management.

Not all third party wireless bridge devices are able to get IP addresses to clients behind them, but the answer
may be to disable a feature from the Ruckus side related to DHCP.  This is an AP CLI command:

rkscli:  set qos directedDHCP disable

ZoneDirector controllers have a CLI command that can communicate with all connected APs, ie:

ruckus(debug)#   remote_ap_cli -A "set qos directedDHCP disable"

but a SmartZone controller would need to use a script that sends the command to all APs.  Can you SSH to the
AP you're testing your bridge device on, and issue this command to see if it helps your clients behind it to pull IP?

KBA-3332: Ruckus WDS with third party wireless bridge
KBA-1423: Clients behind a Third Party wireless bridge are unable to obtain a DHCP IP address
Photo of RedVision81


  • 31 Posts
  • 6 Reply Likes
Thank you Michael, but its still not working.
Pushed the setting to one of my APs next to my desk, but i still cannot connect. even if i set the Bridge to Client or Repeater Mode. And it also doesnt matter if i use DHCP on the Bridge or set a static ip.

Also tried now a TL-WR802N (2,4 Ghz only) Nano Router, but still the same.
Photo of Alan Daniel Chavira

Alan Daniel Chavira

  • 6 Posts
  • 1 Reply Like
I have the same issue, works with static ip but dhcp never works. I try: set qos directedDHCP disable but not work. any suggestions ?