The 9.8 upgrade

  • 1
  • Question
  • Updated 3 years ago
I notice that 9.7.1.0.30 is not listed in the official upgrade path for 9.8 - surely I don't have to downgrade to 9.7.0.0.220 before upgrading?
Photo of Martin Kane

Martin Kane

  • 72 Posts
  • 7 Reply Likes

Posted 3 years ago

  • 1
Photo of Mitchell Axtell

Mitchell Axtell

  • 57 Posts
  • 14 Reply Likes
I upgraded successfully from 9.7.1.0.30 to the 9.8 GA successfully in a lab environment, but would not suggest doing so in production without Ruckus approval. It may be worth opening a support case to verify, as they will likely know more.
Photo of Drew Baldock

Drew Baldock

  • 14 Posts
  • 0 Reply Likes
Is 9.7.1.17 to 9.8 supported?
Photo of Robert Slomka

Robert Slomka

  • 1 Post
  • 0 Reply Likes
Smart redundancy zd1100 needs special procedures ?
Photo of Michael Brado

Michael Brado, Official Rep

  • 1979 Posts
  • 275 Reply Likes
Always refer to Release Notes for official upgrade details. And from the 9.8 RN,
the official upgrade path is from one of these previous releases.

4.1.1. Official 9.8 upgrade paths supported:
• 9.5.3.0.45 (9.5 MR3)
• 9.6.0.0.267 (9.6 GA)
• 9.6.1.0.15 (9.6 MR1)
• 9.6.2.0.13 (9.6 MR2)
• 9.7.0.0.220 (9.7 GA)
• 9.8.0.0.112 (9.8 Beta)
• 9.8.0.0.203 (9.8 LCS)

Always save a backup configuration before upgrading, and it's recommended to
add the version digits to the filename to remind you what version it came from.
If you do need to downgrade, you can reload the previous configuration instead
of factory default.

The issues that have required ZD110s in Smart Redundancy to break SR and
upgrade individually have been resolved in 9.8.

9.8 GA release has been delayed by intense QA testing, and was supposed to
have been released earlier. Many important bug fixes were therefore added to
9.7.1 builds, both .17 and .30, due to need. Please upgrade from a QA upgrade
tested image, per the 9.8 Release Notes.
Photo of Drew Baldock

Drew Baldock

  • 14 Posts
  • 0 Reply Likes
This is unfortunate, I would think 9.7.1.0.30 should be a supported path.

Based on the release notes it makes more sense to upgrade to 9.8 LCS and then 9.8 GA rather than downgrade to 9.7 GA, no?
Photo of Martin Kane

Martin Kane

  • 72 Posts
  • 7 Reply Likes
I need to know how to downgrade from the current 9.8 back down to 9.7.0.0.220 so that I can try again, following the correct upgrade path. Maybe that's why my filtering of Generated DPSKs doesn't work? :)
Photo of Michel Galle

Michel Galle

  • 3 Posts
  • 0 Reply Likes
What is the recommended path to upgrade to 9.8 from an already installed 9.7.1.0 build 17 ?

thanks.
Photo of Michel Galle

Michel Galle

  • 3 Posts
  • 0 Reply Likes
I am in 9.7.1.0 build 17 version, and when I installed it I was not aware it was potentially a deadlock to upgrade.
Photo of Max O'Driscoll

Max O'Driscoll, AlphaDog

  • 322 Posts
  • 77 Reply Likes
I upgraded from 9.7.1.0.17 to 9.7.1.0.30 (a short term bugfix release if I remember correctly) then a week later to 9.8.0.0.b369 - not supported path.
All fine several days later...but perhaps I was just lucky.

Also I'm fairly happy to hard reset to factory, apply previous working firmware (9.7.1.0.30) and import a backup config to get back to where I was (of course it would have taken an irritated hour or two to get there).

Read the release notes, if no issue you can see, contact tech support and ask their opinion on non-supported upgrade path...then try at your own risk!

All good clean fun.
Photo of Martin Kane

Martin Kane

  • 72 Posts
  • 7 Reply Likes
Similarly here, Max. Although the filtering of generated DPSKs has stopped working, the engineer working on the case doesn't believe it's because of the upgrade from 9.7.1.0.30