The SmartZone RestAPI to download config requires timezone parameter, but doesn't specify the format that it requires. Does anybody know it?

  • 1
  • Question
  • Updated 11 months ago
The SmartZone RestAPI to download config requires timezone parameter, but doesn't specify the format that it requires. Does anybody know it?
Photo of Eric R

Eric R

  • 3 Posts
  • 0 Reply Likes

Posted 11 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2114 Posts
  • 297 Reply Likes
If you download the API you should see the Timezone example format.



timeZoneUtcOffset

(Optional) the UTC offset of the client’s timezone (String “+09:30”)

timeZoneUtcOffset

The client’s time zone UTC offset

timezone

AP zone’s time zone

timezone

(Optional) AP’s time zone
(Edited)
Photo of Eric R

Eric R

  • 3 Posts
  • 0 Reply Likes
I'm using the reference here: http://docs.ruckuswireless.com/vscg-enterprise/vsz-e-public-api-reference-guide-3-2-1.html#configura...

I needed to look at the error in the response body to realize that my logic for getting the backupUuid needed fixing, because I was putting nothing into the Url for backupUuid.

The 'Download system configuration file' query is a Get method and requires that the timezone parameter be the Utc offset like your first example, however without the colon. If in PST then the following is correct:
"https://RuckusController:7443/api/public/v3_1/configuration/download?backupUUID=<Uuid>&timeZone=-0800"
Photo of Eric R

Eric R

  • 3 Posts
  • 0 Reply Likes
I'm not sure how to mark this as answered.