SZ 100 external captive portal login. Where to POST?

  • 1
  • Question
  • Updated 2 weeks ago
  • (Edited)
Hi,
I have a SmartZone 100, configured to use an external captive portal with RADIUS. It correctly redirects the user to the external login page. The AAA Test also works fine.
My issue is that the when the user enters the credentials, the POST seems lost in the network....

The external captive portal login page receives the following request:

?nbiIP=192.168.x.y&client_mac=xxxxxxxxxxx&reason=Un-Auth-Captive&wlanName=MY_WIFI&dn=scg.ruckuswireless.com&ssid=MY_SSID&mac=44:1e:98:1e:31:a0&url=http%3A%2F%2Finit-p01st.push.apple.com&proxy=0&vlan=30&wlan=3&sip=scg.ruckuswireless.com&zoneName=WEDtGa9sj1EOy6-qqLWQBw_1570617665657&StartURL=<my external login page URL>&uip=ENCxxxxxxxxx

Then, once it collects the username and password, sends a POST to
https://192.168.x.y:9998/SubscriberPortal/hotspotlogin
with parameters: username, password and the other parameters that came in with the request.

I am not using NBI, should I?
I also tried posting to scg.ruckuswireless.com, but the Url doesn't exist. What am I doing wrong? Where to send the form POST?

I'm following this manual
SZ100VSZE-5.1.1-WISPrPortalReferenceGuide-RevA-20190426.pdf

Thank you
Desperately,
Frullo

Photo of frullo Fragelli

frullo Fragelli

  • 1 Post
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of Michael Carty

Michael Carty

  • 3 Posts
  • 0 Reply Likes
Was there ever a solution on this? We are facing the same issue.