Standalone R700 AP with DHCP issue

  • 1
  • Question
  • Updated 2 years ago
  • (Edited)
Hi everyone,

I'm done configuring an R700 AP as a standalone AP but I always get a different address - 169.254.27.89 with subnet mask of 255.255.0.0 - on my test phone from the configured pool of addresses.

The attached photos are the configurations on the concerned AP:



Any help will be greatly appreciated.

Cheers
Photo of Bar Chiu

Bar Chiu

  • 7 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of John D

John D, AlphaDog

  • 499 Posts
  • 137 Reply Likes
It looks like on your third screen, "Packet Forward" is set to "Bridge to WAN" but you've set up a local subnet with an access VLAN. Perhaps you wanted to NAT to the subnet instead for that option?
Photo of Anusha V V L

Anusha V V L

  • 27 Posts
  • 14 Reply Likes
Change the Packet Forward option to "Local Subnet NAT and route to WAN" and that should fix the issue.

- Anusha
Photo of Bar Chiu

Bar Chiu

  • 7 Posts
  • 0 Reply Likes
This is odd but why do I get a different address on my test phone?


Photo of John D

John D, AlphaDog

  • 498 Posts
  • 137 Reply Likes
169.254 is a link local address. It is common practice that devices will assign themselves a 169.254.0.0/16 address if they are configured for DHCP but no DHCP server responds.
Photo of Bar Chiu

Bar Chiu

  • 7 Posts
  • 0 Reply Likes
I see.

I shifted my test device on a laptop. It brought some good results. Resolved IP address was within the configured range. Changed the Local IP Address (1st picture) as it pertains to the gateway of a subnet.

However, it caught a snag as it looks for a DHCP server. Isn't that the AP was configured as the DHCP server?
Photo of John D

John D, AlphaDog

  • 498 Posts
  • 137 Reply Likes
To confirm, did you try changing the Packet Forward option as suggested by me and Anusha? Without it set to Local Subnet NAT, the DHCP server won't be listening. Ruckus's DHCP server does not listen on the WAN interface, it only listens on local subnets. If you select Bridge to WAN, you won't get the local DHCP server assigning IP's.
Photo of Bar Chiu

Bar Chiu

  • 7 Posts
  • 0 Reply Likes

As attached... I noticed the effect when Bridge to WAN is selected.
Photo of Bar Chiu

Bar Chiu

  • 7 Posts
  • 0 Reply Likes
Case Closed.

Solution: Local subnet is configured with the same subnet where the AP ip is configured.
(Edited)