Stand alone AP (ZF7372) and band-balancing

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I have a ZF7372 running 9.8.1.0.101 and trying to find out how to enable band-balancing via its CLI. I am not running the AP with a ZD as it is a stand alone device. I see the CLI for band-balancing but am not sure how to enable or configure it. I have both the 2.4 & 5Ghz radios running the same SSID's and security settings. Below are you readouts when I look at the band-balancing settings.

Can someone tell me how the commands work and/or the correct settings to move dual band clients over to the 5Ghz radio.

rkscli: get band-balancing
Band Balancing:
Under Mesh AP : Off

rkscli: get band-balancing wlan0
Band Balancing:
wlan0: Disable
Rssi Threshold limit: wlan0, 20
Band Bal limit: wifi0, 0
MinStaThreshold limit: AP, 10
Under Mesh AP : Off

rkscli: get band-balancing wlan8
Band Balancing:
wlan8: Disable
Rssi Threshold limit: wlan8, 20
Band Bal limit: wifi1, 0
MinStaThreshold limit: AP, 10
Under Mesh AP : Off

rkscli: set band-balancing
parameter error
Usage: set band-balancing {options}
-- {|all}
-- mesh-ap {enable|disable}
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
Ruckus doesn't actively promote customer use of AP CLI commands. This might be one reason. An unofficial internal 9.8 AP CLI guide says the commands to balance dual-band clients between AP radios is "band-steering", but as you and I find when we are on an AP, there is no get/set "band-steering", only "band-balancing" options.

On ZD managed APs, band-balancing is enabled by default. On standalone APs,
I cannot determine how to enable it on non-mesh APs. A 'set band-balancing all
15' command takes, and applies the RSSI value, but still shows the feature as
being "Disable". Your single standalone AP may rely on the client driver to make
the band/radio decision. Some Apple devices will prefer 5G in fact.
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like
That is a little dis-heartening as this is a feature that is very helpful. Obviously this is something that is configurable as the CLI commands are there. Ruckus even changed the CLI recently from "band-steering" to "band-balancing" proving that someone is looking at this feature.

Is this just a product of something not working as designed or something that isn't intended to be in the CLI?
Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
On one hand, our capabilities in standalone mode APs today, with multiple internal
VLANs and DHCP, bridge or routing local or NAT, giving even more flexibility for
use at home than any popular wireless router, makes great leaps, allowing Ruckus
advanced antenna APs to replace the Media and MetroFlex product line APs.

But when we look at trying to extend ZoneDirector centered design features down
to a standalone mode AP, there might be differences in standalone *alone* code.
This may be why we don't promote AP CLI usage. 9.8 ZD WLANs have both client
load balancing and band steering enabled by default.

I've found the standalone AP command to both enable band-balancing, set with a
default RSSI value of 20 for initial evaluation, is applied with the 'mesh-ap' option
included (and only), except standalone APs can't do mesh...

I think some AP CLI commands might be for tuning ZD managed APs and/but
don't go away if running in standalone mode. I am investigating this band steering
or balancing configuration on standalone APs issue, and will report back.
Photo of Dmitry Ivanko

Dmitry Ivanko

  • 11 Posts
  • 0 Reply Likes
What about the investigation? Will band steering/balancing work on a stand alone AP? When will this feature work?
Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
Thanks for your patience. Still waiting for the final word from engineering, but here
is some data. Band-Steering is an intelligent way to direct 5G capable clients to
the 5G radio due to its higher capacity. This is done by analyzing client probes, and
clients tend to probe both band radios on an AP, allowing recognition of dual-band
clients. Monitoring tables of client MACs, bands detected and average RSSI, APs
may withhold probe responses or authentication responses to encourage/steer those
clients to the 5G band.

Band-balancing is an intelligent distribution method to try and balance the number
of clients on each band radio. The default minimum station threshold is 10 clients.

You can determine if Band-Steering is enabled and configure the radios to perform
band steering with get/set withholding-limit wifiX commands. On a factory
defaulted 7372 running 9.8.2.0.15, band-steering appears to be enabled with a
7 response parameter, determined by our DEs as best for Mac OSX, Windows 8,
IOS, Android Playstore and Windows RT tablets. ie.

rkscli: get withholding-limit wifi0
wifi0: Withholding limit (auth response): 7
OK
rkscli: get withholding-limit wifi1
wifi1: Withholding limit (auth response): 7
OK
rkscli:

The above results imply that band-steering is enabled on both radios by default.

However, I'm still trying to get Engineering to explain if Band-Balancing is on too,
since the AP CLI "get" command, shows wlan0:Disable in the output.

rkscli: get band-balancing wlan0
Band Balancing:
wlan0: Disable
Rssi Threshold limit: wlan0, 20
Band Bal limit: wifi0, 0
MinStaThreshold limit: AP, 10
Under Mesh AP : On
OK
rkscli:
Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
I have received confirmation from the developers, that not all band-steering and
band-balancing commands are present/working in 9.8 Standalone AP CLI.
They are all being added/fixed in 9.9.x.

BB is enabled by default in ZD mode. Need the same in SA mode.
RSSI Thresh default value is 20 in both modes. No change needed.
BB Percent default values are 25:75 in ZD mode. Need the same in SA mode.

We do have a fairly comprehensive description of both features with default values
in the KBA database: https://support.ruckuswireless.com/an...
Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
Officially, ZoneFlex AP firmware 9.9 will be labeled a 100.0.0.0.128 designation, and will be compatible with ZD, FlexMaster, or Standalone mode. Initial testing of band-steering/band-balancing shows the developers have fixed the problems reported in ZF 9.8. Keep an eye on the AP firmware Downloads page, and on this Forum listing, for the official notice when the new firmware is posted. Thanks.
Photo of Bram Ueffing

Bram Ueffing

  • 7 Posts
  • 0 Reply Likes
Sounds good, thanks for keeping us in the loop. Much appreciated.
Photo of Blake Bernhard

Blake Bernhard

  • 8 Posts
  • 0 Reply Likes
will this firmware be released for EOL products? e.g. 7962
Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
I'm afraid 9.8 is last release for 7962.
Photo of Blake Bernhard

Blake Bernhard

  • 8 Posts
  • 0 Reply Likes
Ok thanks for that I have found that FW above 9.7.0 have several issues preventing my ability to use 40MHZ or for my AP to authenticate my connection.
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like
I appreciate your help on this. I am more interested in the actual Band-Steering over the Band-Balancing. I am in a noisy 2.4GHz environment and want to steer as many devices to the 5GHz range. About 90% of my devices are dual band.

Can you clarify what my commands would be to steer as many device to 5GHz once it is implemented in 9.9?
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
Two things you need to understand here:

1. the decision is always on the client side
2. If the AP is too aggressive on the balancing it might cause the client to not connect to any AP radio at all. So the balancing mechanism NEEDS to be very gentle and clients must be persuaded to the other band not kicked to it.

Yet another thing we saw at a recent stress test was that clients now tend to prefer the 5GHz over 2.4 so you might not be seeing this problem for long anyway.
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 137 Reply Likes
I've had similar experiences as Primoz with modern clients. Before I thought I had roaming/2.4 stickiness issues, when in reality I had poor 5GHz coverage. Now that I have enough AP's to provide a strong 5GHz signal on my premises, I've found that even with no smart-roam and load/band-balancing at play, my clients generally prefer 5GHz.

Currently on my network I have 25 5GHz clients and 4 2.4GHz clients. Of those, 3 only support 2.4GHz. And this includes several Macs and iOS devices that roam around.

I find that especially with smart phones, their 5GHZ reception (And wifi reception in general) is not as good as a laptop/desktop. So while an area might seem sufficiently covered on 5GHz when testing with a laptop, it might be a different story with a mobile device.
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
Another thing you might do is to lower the transmit power of the 2.4G radio. Maybe try -6dB. It will make the cell smaller but the speeds should remain the same. If they drop considerably try using -3dB.

Yet another thing you plan your cells for different RSSI values. Try -67dBm for 5G and -72dBm for the 2.4 band but these values are application specific also.

There are other things to try and consider also but this is what I usually start with.
Photo of Primož Marinšek

Primož Marinšek, AlphaDog

  • 413 Posts
  • 48 Reply Likes
Thanks for the star, but I made a mistake here. It should be the other way around; it's -67dBm for the 2,4gig and -72dBm for the 5gig, since the noise floor of the 5gig band is a lower and the obstacle penetration is somewhat worse.
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like
I see that there is a 100.0.0.0.127 release out. Is this the latest firmware for the AP? If so does this have the fix for the band steering?
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like
I have loaded 100.0.0.0.127 on my test AP. When I run help in the CLI neither band-steering or withholding-limit show. I am able to run the commands though via the CLI. When I do run them via CLI they give me the below:

rkscli: get band-balancing
Band Balancing:
Under Mesh AP : Off

rkscli: get band-balancing wlan0
Band Balancing:
wlan0: Disable
RSSI Threshold: wlan0, 20
Band Balancing Percent: wifi0, 25
MinSta Threshold: AP, 10
Under Mesh AP : Off

rkscli: get band-balancing wlan8
Band Balancing:
wlan8: Disable
RSSI Threshold: wlan8, 20
Band Balancing Percent: wifi1, 0
MinSta Threshold: AP, 10
Under Mesh AP : Off

rkscli: get withholding-limit wifi0
wifi0: Withholding limit (auth response): 1

rkscli: get withholding-limit wifi1
wifi1: Withholding limit (auth response): 1
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like
I was wondering if there was any update on this. I can see where .128 is now out. Last Michael Brado was looking into this.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2087 Posts
  • 289 Reply Likes
Hello Erik,

Yes, you need to issue "set band-balancing wlanX enable"

CLI command on standalone AP:

rkscli: get version
Ruckus 7055 Multimedia Hotzone Wireless AP
Version: 100.0.0.0.25
OK
rkscli: set band-balancing
parameter error
Usage: set band-balancing {options}
                  -- {<wlan name>|all} {enable|disable}
                  -- {<wlan name>|all} rssi <value>
                  -- <wifi name> percent <value>
                  -- minsta <value>
                  -- mesh-ap {enable|disable}

rkscli: set band-balancing wlan9 enable
OK
rkscli:


rkscli: get band-balancing wlan9
Band Balancing:
         wlan9:  Enable
         RSSI Threshold: wlan9, 20
         Band Balancing Percent: wifi1, 0
         MinSta Threshold: AP, 10
         Under Mesh AP : Off
OK
rkscli:
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like

I might have to start this dialog over again.  I have been pulling apart the CLI for a while now and am only having issues with two items, Band-Balancing and Band-Steering.  From what I get out of this thread Band-Balancing is configured with the "set band-balancing" command while Band-Steering is done with "set withholding-limit" Am I correct?

As I had stated, I am more interested in Band-Steering. Can someone please explain the "set withholding-limit" command to me as I am not sure about it.  I would think that setting a high # (over 7-10) on the WiFi0 while a low # (1) on WiFI1 would cause devices to the 5GHz radio.  Is this how the logic for this command works?

Photo of Michael Brado

Michael Brado, Official Rep

  • 2098 Posts
  • 295 Reply Likes
How does Ruckus Band-Steering work?

Band-steering Design introduces a data structure shared by both radios of an AP.
In the structure, APs maintain a table of clients.
Update the table with each detected probe request.
Remember whether the client has dual-band capability.
Measure average RSSI per band, within the last minute.
Limit table size, delete inactive entries.
Check the table before responding to 1) Probe Requests, 2) Authentication requests

Band steering is enabled by default and the default threshold value is 20 db. If the client Ruckus detected by "probes" (looking for AP's) in both 5GHz and 2.4GHz has good power in both, the AP with "band steering" on, will respond only with "probe response" in the 5GHz for the client where connected to that radio.

RSSI threshold values:

Typical: 20
Steer all: 1
Disable: 0

Values are persistent at each AP per WLAN
rkscli:
get  band-steering-rssi-thresh wlan<N>
set  band-steering-rssi-thresh wlan<N>  <value>

Refusing Authentication:

If client requests authentication on 2.4g, and
AP has previously detected client on 5g, and
Client does not appear to be in distress 
 - sufficient RSSI[1] on 5g within the past minute, or else
 - sufficient RSSI[2] on 2.4g within the past minute, and
AP is not a Mesh AP, then
refuse authentication on 2.4g

[1] Threshold for 5g is the CLI value for this WLAN
[2] Threshold for 2.4g is the CLI value plus adjustment per client when AP has concurrent measurements.

Withholding Probe Responses:

If client is probing on 2.4g, and
AP previously detected the client on 5g, and
One of the following
 - AP has not detected probes from client in past minute, or
 - Client does not appear to be in distress (see Auth Refusal), and
AP is not a Mesh AP, then
withhold probe response on 2.4g.

Note: Clients try to authenticate even when the AP does not respond to its probes, so withholding probe responses alone is not sufficient to steer clients.
Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like

This is getting more confusing.  I have a 7372 running 100.0.0.128 now and don't even see the CLI commands for the band-steering.  I have looked at every command in the CLI and don't see anything about band-steering. 


I don't want band-balancing on as I want everyone that can go to 5GHz that can do so.  I have set what I think is the correct band-steering setting ( withholding-limit wifi# ) to 15 for wifi0 & 1 for wifi1.  From what I have read on this post and you link this should withhold responses on the 2.4GHz.

Can you please tell me what I am missing?


This is what I am getting from my AP:


rkscli: get  band-steering-rssi-thresh wlan0
Command is not recognized: get  band-steering-rssi-thresh wlan0


---------------------------------------------------------


rkscli: get band-balancing
Band Balancing:
         Under Mesh AP : Off
OK
rkscli: get band-balancing wlan0
Band Balancing:
         wlan0:  Disable
         RSSI Threshold: wlan0, 20
         Band Balancing Percent: wifi0, 25
         MinSta Threshold: AP, 10
         Under Mesh AP : Off
OK
rkscli: get band-balancing wlan8
Band Balancing:
         wlan8:  Disable
         RSSI Threshold: wlan8, 20
         Band Balancing Percent: wifi1, 0
         MinSta Threshold: AP, 10
         Under Mesh AP : Off
OK


----------------------------------------------------------


rkscli: get withholding-limit wifi0
wifi0: Withholding limit (auth response): 15
OK
rkscli: get withholding-limit wifi1
wifi1: Withholding limit (auth response): 1
OK
rkscli:

Photo of Erik Farey

Erik Farey

  • 11 Posts
  • 1 Reply Like
BUMP....   Anything new on this?  Still having the same issue.