Speedflex Question - Huge Gap between Up- and Download

  • 1
  • Question
  • Updated 2 years ago
Hello,

recently i was on Customer Site to check wireless throughput with Speedflex.
After testing some iPhones i tried to check a Windows 7 PC connected over 802.11ac.

Speedflex Tool reported me a Download Speed about 180Mbit/s and an Upload about 39Mbit/s.
Any Idea why there is such a huge gap between Up- and Download?

Thanks!

Kind Regards
Marco
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes

Posted 2 years ago

  • 1
Photo of JS

JS

  • 9 Posts
  • 1 Reply Like
Marco,
     What were your test results with the iPhone(s)?
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes
Hi,

iPhones (Version 6) results vary.
I am not able to say any more if the Phones were connected over 2.4GHz or 5GHz.

There were different Results:
- UP: 93Mbit/s + DOWN: 95Mbit/s
- UP: 56Mbit/s + DOWN: 30Mbit/s
- UP: 187Mbit/s + DOWN: 172Mbit/s

I saw iPhone Speedflex is doing TCP. If i start Speedflex on my ZoneDirector to try the throughput to a Windows Client Speedflex is working with UDP.

But with my Phones there was not that kind of gap.

Thanks.
KR
Marco
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 137 Reply Likes
There could be a number of reasons for that. Some phones don't have the same MIMO diversity / number of spatial streams for the transmit side vs the receive side.

Others don't have terribly good transmit power or antenna design, so they can receive the strong signal from the Ruckus AP and have good downstream, but are not as good at transmitting back.
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes
Thanks John Dong.
The Wireless Adapter we are talking about is a Netis WF2190 AC1200. Wireless Chipset is from Realtek. Adapter has 2 Streams for Transceive and 2 for Receive. The Realtek Software shipped with this Adapter reporting me a (theoretical) speed of 867Mbit/s Up and Down. This whould be a dream. ;)

So if i understand you right it could be a Problem with the Wireless Adapter / Antenna itself.
Unfotunatelly i dont have other Adapters for testing with Windows 7.

If there are any other ideas for my gap issue, please give me a feedback.
If someone has a good experience with a USB AC Adapter working fine with Ruckus (R500), dont be shy and write it down. Thanks.