SNMP v3 is not working properly in ICX6450 switches

  • 1
  • Question
  • Updated 1 month ago
  • Answered
can you please share the valid configuration of SNMP ver3 in ICX6450 as I configured it but the SNMP agent did identify or get data from my switches
Photo of reda sh

reda sh

  • 3 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 129 Posts
  • 40 Reply Likes
Hello Reda sh,

The switch config is very straightforward, Pls watch a short video on it.


https://www.youtube.com/watch?v=x_BDNSZJAaY

 Additional Questions - 

1) Firmware version you are running on the switch.
2) Did you check the reachability end to end.
3) Any specific error message when you send GET request


Thanks
Jijo 
Photo of chris tagg

chris tagg

  • 2 Posts
  • 1 Reply Like
Is there an SNMPv3 setup equivalent video ?
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 129 Posts
  • 40 Reply Likes
Hey Chris,

Perhaps not ! If you are looking for a config examples, we have it covered in FI management config guide. Pls look for 'SNMP v3 configuration examples'

http://docs.ruckuswireless.com/fastiron/08.0.70/fastiron-08070-managementguide/GUID-F0E639A2-5109-49...


Thanks
Jijo 
Photo of chris tagg

chris tagg

  • 2 Posts
  • 1 Reply Like
Hi Jijo

I'd looked at those. It turned out that my snmpwalk command was missing the mandatory level option! 

So for anyone looking later, you can use this command to snmpwalk the switch once you have configured v3 as per the examples in Jijo's link. This proves you've done it correctly! 

snmpwalk -v 3 -a MD5 -A password1234 -x AES -X password1234 -l authPriv -u admin2 x.x.x.x<switch IP>
Photo of Jijo Panangat

Jijo Panangat, Employee

  • 122 Posts
  • 40 Reply Likes
Great Chris!

Glad that you've figured it out.

Thanks
Jijo