Smartroam function and Sticky client

  • 1
  • Question
  • Updated 2 months ago
  • In Progress
Hi all,

We have ZD 3000 and about 50 APs. For high destiny environment, i've configure smart roam + bss min-rate (following this article: https://forums.ruckuswireless.com/ruckuswireless/topics/bss_minrate_vs_smart_roam)

1/ The config result is below:
In AP R310: show config for smartroam & bss min-rate (wlan0: 2.4Ghz | wlan32: 5Ghz)

rkscli: get bss-minrate wlan0
wlan0 BSS Min Rate: 5500 kbps
OK

rkscli: get bss-minrate wlan32
wlan32 BSS Min Rate: 5500 kbps
OK

rkscli: get roam_enable wlan0
wlan0: SmartRoam for sticky clients:  Enabled
OK

rkscli: get roam_factor wlan0
wlan0: Roam Factor (scale=1-10): 5
(Lower factor means more stickiness)
OK

rkscli: get roam_enable wlan32
wlan32: SmartRoam for sticky clients:  Enabled
OK

rkscli: get roam_factor wlan32
wlan32: Roam Factor (scale=1-10): 5
(Lower factor means more stickiness)
OK

2/ The result when client connect to this AP

rkscli: get client-info wlan0
dc:9b:9c:50:28:8b {
    Allow       : Y
    Group       : 4
    OS/Type     : iOS
    Hostname    : AnneVs
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.106.187
    Lease_time  : 17890
    Xid         : 16d73e89
    Drop        : 0
    Ack         : 18
    CUI         :
}
1c:77:f6:ca:c3:1a {
    Allow       : Y
    Group       : 3
    OS/Type     : Android
    Hostname    : android-37226b76ad4dd42c
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.101.126
    Lease_time  : 17787
    Xid         : 918b6e9
    Drop        : 0
    Ack         : 3
    CUI         :
}
--------
summary:
    Android         :   1 ( 50.0%)
    Apple_iOS       :   1 ( 50.0%)
OK

rkscli: get client-info wlan32
64:76:ba:15:f7:c6 {
    Allow       : Y
    Group       : 0
    OS/Type     :
    Hostname    :
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.11.118
    Lease_time  : 0
    Xid         : ccada9d9
    Drop        : 0
    Ack         : 0
    CUI         :
}
c8:1e:e7:29:37:f6 {
    Allow       : Y
    Group       : 4
    OS/Type     : iOS
    Hostname    : iPhonecennytran
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.104.34
    Lease_time  : 17869
    Xid         : 1f497617
    Drop        : 0
    Ack         : 3
    CUI         :
}
54:e4:3a:91:37:9c {
    Allow       : Y
    Group       : 0
    OS/Type     :
    Hostname    :
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.106.240
    Lease_time  : 17853
    Xid         : 583b37ba
    Drop        : 0
    Ack         : 0
    CUI         :
}
e4:47:90:d8:3b:b8 {
    Allow       : Y
    Group       : 3
    OS/Type     : Android
    Hostname    : android-e4ab191e8ea71ab8
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.106.238
    Lease_time  : 17876
    Xid         : 8f3fda62
    Drop        : 0
    Ack         : 1
    CUI         :
}
00:f7:6f:9f:ec:0d {
    Allow       : Y
    Group       : 4
    OS/Type     : iOS
    Hostname    : EmmaNejnsiPhone
    Fwd_policy  : 0(Default)
    Vlan        : 23
    Dhcp_ip     : 10.50.106.209
    Lease_time  : 17913
    Xid         : 28bd4d3d
    Drop        : 0
    Ack         : 3
    CUI         :
}
--------
summary:
    Unknown         :   2 ( 40.0%)
    Android         :   1 ( 20.0%)
    Apple_iOS       :   2 ( 40.0%)
OK
=> It's mean, only 6 clients connect to this AP (2.4Ghz: 1 client, 5Ghz: 5 clients)

But when i do command get stations info, the result is

rkscli: get station wlan0 info
MAC Addr          AID Rate RSSI VLAN Idle ERP State Flags RecvSigStrength
-------------------------------------------------------------------------
38:d4:0b:cf:a4:04  23   6M   14   23  120   0  202f     0             -98
0c:d7:46:35:04:bd  11   6M   16   23  105   0  202f     0             -96
a0:cb:fd:49:e0:5e  68   6M   13   23    0   0  202f     0             -99
ec:85:2f:21:cb:62  16   6M   13   23  210   0  202f     0             -99
14:8f:c6:24:04:95   2   6M   18   23    0   0  202f     0             -94
44:78:3e:d2:9a:a5  10   6M   16   23   15   0  202e     0             -96
24:00:ba:8e:57:94  20   6M   15   23  180   0  202f     0             -97
24:a2:e1:c7:fb:af  25   6M   12   23  210   0  202f     0            -100
40:d3:ae:8d:ce:f0   4   6M   19   23  210   0  202f     0             -93
68:db:ca:a9:b5:ff  27   6M   17   23  180   0  202f     0             -95
00:56:cd:5f:c8:d5  33   6M   26   23  180   0  202f     0             -86
a0:d7:95:a9:32:d3  34   6M   13   23  180   0  202f     0             -99
0c:d7:46:5e:58:b8  30   6M   14   23   75   0  202f     0             -98
90:e7:c4:04:0f:c2  42   6M   15   23   75   0  202e     0             -97
94:fe:22:d1:c2:75  38   6M   17   23  180   0  202f     0             -95
50:9e:a7:79:4b:91   3   6M   17   23  165   0  202f     0             -95
34:97:f6:ae:34:a3  15   6M   13   23   60   0  202f     0             -99
80:01:84:35:2c:62   8   6M   17   23  255   0  202f     0             -95
24:92:0e:df:aa:d2  12   6M   14   23  210   0  202f     0             -98
e0:c7:67:62:08:e1   7   6M   16   23  240   0  202f     0             -96
ac:5a:14:35:2f:69  14   6M   23   23  210   0  202f     0             -89
d8:5b:2a:59:81:67   6   6M   19   23  165   0  202f     0             -93
38:d4:0b:e9:69:20  29   6M   16   23  135   0  202f     0             -96
38:aa:3c:90:c9:4b  13   6M   14   23  135   0  202e     0             -98
00:f4:b9:33:12:0c  26   6M   15   23  210   0  202f     0             -97
b4:8b:19:29:16:ed  32   6M   17   23  150   0  202f     0             -95
a4:c3:61:0d:57:fc  17   6M   14   23  210   0  202f     0             -98
60:f4:45:74:8e:e7  24   6M   13   23   75   0  202f     0             -99
1c:87:2c:83:32:f6  22   6M   13   23   90   0  202e     0             -99
54:9f:13:47:60:37   1   6M   17   23  180   0  202f     0             -95
f8:23:b2:97:a9:05   9   6M   13   23  240   0  202f     0             -99
c0:9f:05:23:0f:f8  31   6M   13   23   60   0  202f     0             -99
d0:59:e4:cd:ad:2b  35   6M   14   23   60   0  282f     0             -98
20:c9:d0:70:4d:07  36   6M   13   23   45   0  202f     0             -99
34:8a:7b:64:d4:52  37   6M   16   23   60   0  202f     0             -96
c8:f2:30:c4:9f:4b   5   6M   21   23   45   0  202f     0             -91
c0:c1:75:04:85:c5  39   6M   13   23   90   0  202f     0             -99
d8:5b:2a:2f:ac:55  19   6M   27   23    0   0  202f     0             -85
d0:17:c2:49:eb:f7  28   6M   23   23  240   0  202f     0             -89
e8:80:2e:af:95:aa  18   6M   14   23  210   0  202f     0             -98
1c:77:f6:ca:c3:1a  21   6M   16   23   30   0    2e     0             -96

OK

=> Many client connect this AP with low RSSI (< 20 db). If Smart-Roam is working well, those clients need to be disconnected.


In monitor tab (from ZD3000), i see this AP has 101 clients connected, but those client is not real. I search some client mac-address on whole system, and can't found any logs in any devices (Access switch, Core Switch or Internet gateway).
When i reboot this AP, number of clients will be reduce to 5 or 6.

So, please help me to figure out, why this AP keep remain old clients. 

Thanks a lot!

 
Photo of An Nguyen

An Nguyen

  • 13 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 1892 Posts
  • 269 Reply Likes
Hello An,

   Very curious info.  I suggest to run latest ZD firmware that supports all your AP models,
and turn off SmartRoam to get some better baseline details.  Where density has led to
using SmartRoam in the past, we've never needed to use higher than level 3.  Maybe
compare no SR to level 3 implementation after upgrade to current MR? 

   ZDs can show clients still connected in the WebUI, who haven't passed a session timeout,
in case they come back into range/power on again, but I have only seen Active associations
when checking an AP's 'get station wlan0 info' command, so that's what's curious to me.
You're rebooting the AP kicks everyone off, so only a few had reconnected, btw.
(Edited)
Photo of An Nguyen

An Nguyen

  • 13 Posts
  • 0 Reply Likes
Hi Michael Brado,

I've change roam_factor from 5 to 3, and monitoring in half of day. This issues still happens.

As your comment " ZDs can show clients still connected in the WebUI, who haven't passed a session timeout, in case they come back into range/power on again"

In my configuration, Inactivity timeout: 5 minutes.
But, let's check some random client on this AP.
- Client connect from 30 minutes ago

- Although, this client can't receive IP from DHCP Server, and it's not exchange any packet with AP. But it's still connect.




P/s: I'll prepare plan for upgrading firmware in next week and keep tracking.