Smart-Roam on 7341 AP (v. 9.5)

  • 1
  • Question
  • Updated 2 months ago
Hi all,

I've taken over management of four Ruckus 7341 Multimedia Hotzone Wireless APs over two separate sites (all Software Version 9.5.0.0.156)

Regardless of the roaming agressiveness we set on our Windows 7 wireless interfaces, the devices seem to excessively stick to an AP.

Without requiring a controller (ZD), I've heard mention of a Smart-Roam functionality (configurable via SSH/CLI), which causes the AP to pretend to go out of range - and force roaming: see https://forums.ruckuswireless.com/ruckuswireless/topics/optimizing-client-switching-between-access-p...

However, I can't see that the relevant CLI commands (set roam_enable, set roam_factor) are available.

Should these commands be configurable in Software Version 9.5.0.0.156?

Many thanks in advance,

IR8
Photo of irobot8

irobot8

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2183 Posts
  • 301 Reply Likes
Good morning IROBOT8,

    Glad to have feedback from a new user.  Roaming decisions are made by the client radio driver/supplicant,
based on various factors including RSSI, interference and others.  Ruckus APs have inherent patented antenna
technology that performs really well.  If your client still has a good strong signal to the AP it first connects with,
it may not see any reason to "roam", even if you stand close to the other AP (depending on how far apart they are).

    Take a look at the text Support Info file from the AP that your Win7 client is connected to.  Look for the Win7
client MAC address in the file, and you'll eventually find the info it's reporting back to the AP it's talking to, that
looks something like this:

STA: 00:19:70:b1:f3:7c
    rx_data_frm 9874 rx_mgt_frm 1 rx_bytes 989174 rx_dup 87
    tx_data_frm 20720 tx_mgmt_frm 3 tx_bytes 2034916
    tx_assoc 1 tx_auth 1
    good_tx_frms 20723 good_rx_frms 9875 tx_retries 839
    tx_rate 24000 tx_kbps 24249
    ack_rssi 41 rx_rssi 42

This STAtion, reports an rx_rssi = 42.  That's a good strong signal.  There's no PER (packet error rate)
coming from interference near the client.  Clients probably won't want to roam until RSSI < 25.
(Edited)
Photo of irobot8

irobot8

  • 2 Posts
  • 0 Reply Likes

Many thanks for the detailed reply Michael.

When you say "Roaming decisions are made by the client radio driver/supplicant", does this mean - e.g. for laptops - that setting the roaming aggressiveness on the Wireless NIC driver is the only way of controlling roaming?

Otherwise, are the following methods also able to control roaming behaviour to some degree?

1. Smart-Roam functionality - configurable via SSH/CLI - which causes the AP to pretend to go out of range and force roaming (see https://supportqa.ruckuswireless.com/answers/000002277)

2. 802.11r fast transition method and 802.11k ability to send Wi-Fi clients the best potential access points for roaming (as far as I understand, these features can only be enabled by purchasing a controller/Zone Director)

Do you know if the above 2 methods are able to help us improve roaming behaviour?


Photo of Srikrishnan Mahadevan

Srikrishnan Mahadevan

  • 2 Posts
  • 0 Reply Likes
Hi 
I have the same issue as IR8.  After upgrading to the latest firmware version 200.5, I lost the smart-roam setting and no way to set it to the value I set in the earlier version 200.1.  Anybody knows how we can set this in 200.5