Smart Redundancy Initial Setup

  • 1
  • Question
  • Updated 3 years ago
Hi guys. I was setting up our customer's two ZD5000 in Smart Redundancy. However, I encountered a problem wherein when the standby ZD (IP and SR are the only thing configured) went online, the APs which already got all the WLAN configuration from the Active ZD, failover to the standby ZD which has not yet synchronized with the previous Active ZD, therefore, the APs lost all the WLAN configuration. Mesh APs got isolated (this was a pain to restore!). Not only that but the standby ZD (now the active) synchronized its empty WLAN configuration to our original Active ZD. Good thing I made a backup of the previous active ZD's configuration so I was able to restore everything.

My question now is where did I go wrong in setting up Smart Redundancy? I remember disabling Automatic Approval of APs on the standby ZD before I connected it to the network. This is the second time that has happened to me so I'm thinking my procedure is wrong. I hate to get this happen again in my future deployments especially on existing setups where customer just want to add another ZD for redundancy.
Photo of M

M

  • 30 Posts
  • 2 Reply Likes

Posted 3 years ago

  • 1
Photo of Rahul Koul

Rahul Koul, Employee

  • 75 Posts
  • 12 Reply Likes
Last step in configuring Smart redundancy is where ZD asks whether you want to "Sync from peer" or "Sync to peer". If you do not select one of the two then you basically have two active ZDs at that point in your network and both of them until synced will have their own configuration.

You should see the above option under Configure :: System :: Smart Redundancy.

Hope this helps.

Rahul
Photo of M

M

  • 30 Posts
  • 2 Reply Likes
We did that before we had the issue and it worked. However, due to troubleshooting of another issue, we tried a factory reset on the standby ZD. After that, we did not see the sync to peer or sync from peer option. Standby ZD just suddenly became active after setting up Smart Redudancy.
Photo of Michael Brado

Michael Brado, Official Rep

  • 2104 Posts
  • 297 Reply Likes
Hello M,

In this situation, on the Configure/Access Points page, under AP Policies where
you un-checked the auto-approval box, we would have advised to enter both ZD
IPs under Limited ZD Discovery, while all APs are talking to your Primary ZD. The
APs would be updated with both ZoneDirector addresses to try, when you then
did configure SR between your ZD5Ks, even if your Standby had to be reset.