Secure Hotspot

  • 1
  • Question
  • Updated 6 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: ok to archive, over 1 year, answered

Hi,

I am just trying in my lab Secure Hotspot implementation with evaluation scripts (http://www.ruckuswireless.com/technol...). What version of ZoneDirector must be installed to get it works? I am on 9.5.1.0 build 50
ang getting this message from ZD:




REQUESTDPSK <ruckus><req-password>nbpassword</req-password><version>1.0</version><command cmd= "generate-dpsk"><dpsk expiration="2" key-length="8" user="hotspot" password="secure" mac="7c:61:93:3f:92:e1" vlan-id="1" wlan="secure-dspk"/></command></ruckus>

....

RESPONSEDPSK <ruckus><version>1.0</version><response-code>305</response-code><message>Command parameter not supported</message></ruckus>


I have seen documentation and it seems XML is right.

Thanks in advance.
Alberto.
Photo of Alberto de la Cruz

Alberto de la Cruz

  • 42 Posts
  • 1 Reply Like

Posted 6 years ago

  • 1
Photo of Sid Sok

Sid Sok

  • 102 Posts
  • 49 Reply Likes
Correct you can use 9.5.1.0.50. Make sure you follow the sample instruction on setting up the correct Northbound Interface password and the hard coded secured wlan service in your ZD's wlan configuration page:

Default NBI password: testme123
Default Secured (PSK) wlan: hotspot-secure

In your sample above you will need to add a secure (psk) wlan called: "secure-dspk" Note the spelling in the request and not "secure-dpsk"
Photo of Alberto de la Cruz

Alberto de la Cruz

  • 42 Posts
  • 1 Reply Like
Ok, thanks,

I fixed this issue but I get the same error. Northbounf interface seems to be well configured because user is authenticated but redirection is not done.

Regards
Alberto
Photo of Sid Sok

Sid Sok

  • 102 Posts
  • 49 Reply Likes
What error are you getting? Is this on the client side? Can you post a screen shot or the error message?
Photo of Netgirl

Netgirl, Official Rep

  • 4 Posts
  • 1 Reply Like
Alberto,

I believe the problem here is the expiration time you have set. I double-checked and the current minimum value is 24 hours. So a value of "2" will not work which is why you are getting the invalid parameter response; the value of 2 is not a valid parameter for expiration.

Fewer hours should be allowed. I'll enter a feature request for you.
Photo of Alberto de la Cruz

Alberto de la Cruz

  • 42 Posts
  • 1 Reply Like
Hi Netgirl!

Thanks. Now is working.

Regards
Alberto.

This conversation is no longer open for comments or replies.