second ethernet port on R720 not supporting NAS

  • 1
  • Question
  • Updated 1 month ago
  • Answered
Hi there.  Have a single ethernet line going to an outbuilding where I have an R720.  As this is the closest I have to "offsite" this is where I want to put my critical data backup NAS.  However, when plugged into the spare ethernet port in the R720, the NAS is not discoverable on my network. The PoE switch powering the R720 has plenty of power budget so this isn't the issue.

Just wondering if I need to change a setting that I am unaware of in my ZD1200 to enable a wired client on my R720.  

Many thanks.
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes

Posted 1 month ago

  • 1
Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 209 Posts
  • 117 Reply Likes
HI Peter,

Can you confirm that your R720 is being powered with 802.3at PoE power (upto 30w)?

If your switch is only sending 802.3af (15w) power, then the R720's second ethernet port will be disabled.

It should be easy to diagnose on the AP itself as the port LEDs won't be lit once you've connected your NAS.

If you have checked the above and your AP is getting enough power, then it might be a MDI/MDIX issue. I experienced this recently with an iMac plugging directly into an AP's second port.  It may be possible to configure this on your NAS or you may need to use a crossover Ethernet cable.

I hope that helps,
Darrel.
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
I have an ICX 7150 12 port switches - power budget 128W I think.  Each powering just 3 R720s, so I should have the power budget. 

I was wondering if it might be the length of the cable run which is dissipating the power?

If there's no obvious solution I may just put the critical data backup NAS somewhere in the house instead.


Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 207 Posts
  • 116 Reply Likes
Hi Peter,

Great to hear you have the ICX7150 too.  However just because your switch has plenty of power budget (124W) - it doesn't guarantee the port is automatically providing the correct PoE power.  This will depend on the firmware version and whether you're running LLDP, etc.

The ICX switch will provide 30 watts 802.3at power with no issue for upto 100 metres on CAT5e.

You should be able to connect as you want but it looks like you might need a tweak to the config on the switch or your NAS.

Thanks,
Darrel.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 357 Posts
  • 129 Reply Likes
Hi Peter,

Just to add on what Darrel suggested, try SSH into the AP and check if AP is negotiating to 802.3at power.

get power-mode

if output shows that it is negotiating on 'af' then force the AP to get 'at' power using below command (assuming that your switch supports 802.3at).

set power-mode at



Above is the chart from data sheet, which shows Power vs Operation characteristics of R720.

Also run below command to check eth port status, after connecting a device on 2nd port of R720.

get eth

Regards,
Syamantak Omer
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
Many thanks.  I have CAT 6 and I doubt its more than 100m cable run as my switch is in the basement and the outbuilding is only about 10m from the house.  

I'm not experienced in SSH but think I can go to the web interface for the ICX switch and check on power budget.  I think I can also play with the power via the console lead to the power switch.  Sounds like a project for the weekend.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 351 Posts
  • 125 Reply Likes
Hi Peter,

I was referring to R720 AP for SSH, not ICX.

It is very simple, refer the example below.

1- Download a CLI console client, like putty.
2- Open putty and use AP's IP address and ZD's login credentials to login into AP CLI.


3- Once you are in, run the advised commands in my last comment.

Regards,
Syamantak Omer
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
Many thanks.  This sounds doable.  Will try over the weekend.  Thanks for making this easy for me.
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
OK I started down this route but to me it looks like I am supposed to do this through the ZD UI.

From the SSH I have two pics and one from the ZD IU.
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
I thought I should seek further guidance before messing with any settings.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 354 Posts
  • 127 Reply Likes
Ok, so CLI output of get power-mode is showing that AP is negotiating with "af" power, not "at".

And yes, you are on right place to make this change from ZD GUI but there is another better option.

Go to ZD GUI >> Access Points >> Select and edit the AP group (not sure if you have created multiple AP group or just have "Default") >> Model specific settings >> Choose R720 from the drop down >> Choose "802.3at PoE" >> hit OK.

Now this should force existing and any AP connecting in future to this AP group to negotiate with "at" power (if switch is capable).

Regards,
Syamantak Omer
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
Thanks, but isn't this wasteful of electricity?  I have five R720s and only need one of them to support a wired client.  Also, should I select AT or AT+?  Many thanks, Peter
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
Or will AT / AT+ improve the AP performance anyway?
Photo of Caveman

Caveman

  • 41 Posts
  • 4 Reply Likes
to get it up & running, can you not just stick a WIFI dongle in the NAS?
Photo of Peter W

Peter W

  • 95 Posts
  • 4 Reply Likes
I don't think it's either necessary or a great solution to buy a dongle and switch from hard wiring to wireless.  Happy to wait for my questions to be answered and to resolve this properly. Thanks anyway.
Photo of Caveman

Caveman

  • 41 Posts
  • 4 Reply Likes
From other post
You will need atleast 35W POE just to get the second port to kick on.
The correct "solution" would be to run another cable, not try to "daisy chain" off of a AP... becasue colisions & routing will become an issue...

Then there is the "physical" limit of the wattage over the length of the cable....
(Edited)
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 357 Posts
  • 129 Reply Likes
Hi Peter,

All three possible ways to force the AP to 'at' PoE power are already shared.
  1. Using AP CLI (per AP)
  2. Using ZD GUI >> AP group
  3. Using ZD GUI >> per AP.
It depends upon the uses whether you should enable it on all the APs or just one AP or some number or APs. Though running R720 on af power will reduce its wireless capabilities/performance.

I am sharing the Power supply vs Operating Characteristics again for everyone's understanding.



If you look and compare 'af' vs 'at' mode then you will find both radios (2.4 and 5G) enable 1 chain, means throughput will decrease.

With 'at' power supply you get 3 benefits.

1- Both radio will work with 4x4 chains/spatial streams
2- 2nd Eth port will be enabled
3- USB port will be enabled (USB port can be used to plug a compatible IoT dongle, if this feature is required).

Further if you use PoH, then AP will work with its max power per chain, 23 dBm for 2.4 and 22 dBm for 5 G radio, unlike 18 dBm for 2.4 and 20 for 5 G radio on 'af/at'.

I strongly suggest to use 'at' power, rest is upto your use case and requirements.

Regards,
Syamantak Omer