Ruckus ZD 3000 with Purple Portal on an external network

  • 1
  • Question
  • Updated 2 years ago
Hi all,

We've been using a ZoneDirector for quite some time now which has been running internal and public networks perfectly, but have hit a small issue when trying to integrate Purple Portal into the public wifi.  As they claim to integrate fine with Ruckus, I was hoping somebody here would have a similar issue and maybe some advice.

To start off with, all traffic on our public wifi is VLAN tagged so that it goes out over a completely separate network, which is connected via a BT ADSL modem (we're an academic institution, and have to keep public access off of our own internet connection).  This has been working for ages without any problems, but we've now been told to provide some stats on visitors using the service (PurplePortal was recommended).  On trying to set up a test network using a PurplePortal hotspot service, it then attempts to connect back to wireless.mydomain.com (the ZoneDirector's address) to complete the authentication.  However, as it's on a completely separate network, this doesn't work.

Putting the test network on our internal network works perfectly, as it's able to resolve this name and connect properly.  As stated above though, it has to be on an external network.  One possible solution would be to publish the ZoneDirector's DNS name externally, but I'd rather avoid this if possible.  Would it even work if I did so?  I could set up a firewall rule to restrict access to the public network, but I'd still rather avoid this if possible.

We're running firmware 9.12.0.0 on a ZoneDirector 3000 if it helps.  Any advice anyone can provide will be greatly appreciated!

Thanks in advance.
Photo of RBGE

RBGE

  • 9 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Andres Arizpe

Andres Arizpe

  • 3 Posts
  • 0 Reply Likes
Hi RBGE,

Don't know if this is still relevant after 5 months but I'll stil give it a shot.

I would suspect this is an ACL issue or inter VLAN routing issue because Purple WiFi does not care which Internet link you use to access it as long as you have local access to the ZD.

Try pinging the ZD ip address from your guest network and my guess is that there is no response.
Therefore you are blocking access from the public to the private network somplace (either at the ZD or your switch or firewall). Once you figure out where the block is, just allow access to the ZD IP and you should be all set.

Hope this helps,
Andres
www.fastweb.comm.x