Ruckus Unleashed R510's constant heartbeat loss

  • 1
  • Question
  • Updated 3 months ago
  • Answered
I moved into a new construction home about 6 months ago (amazon smart home) that came with three Ruckus AP's. I am experiencing heartbeat loss about every hour. It becomes difficult to work. I have been on the phone with ruckus customer support for months trying to figure out the heartbeat loss issue and i have gotten no where. We replaced the switch and that has not helped. We have updated the firmware. We have ran tests for over 24 hours. Have gotten no where and I still have constant heartbeat loss issue.

Can anyone help how we can have a steady wireless connection without our wifi disconnecting every hour? This issue is driving me insane.
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes

Posted 4 months ago

  • 1
Photo of MLG

MLG

  • 88 Posts
  • 27 Reply Likes
Have you tried replacing the cable? If that’s not possible in its current position, try a new cable closer to the switch temporarily. Secondly, check your IP settings for the access point, is it set to DHCP or static? If it’s set to static IP, there could be an IP conflict, switch to DHCP and reboot AP. 
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes

That didn't seem to work. i have android. can you guide me how to choose an ip address?
Photo of MLG

MLG

  • 88 Posts
  • 27 Reply Likes
I don’t know what DHCP range your router is giving out. I would guess not less than 100, can you try 192.168.0.99? It is difficult to troubleshoot further for me online, I would recommend doing a hard reset of your switch by pressing the reset button with a paper clip for 10 seconds and see if the Unleashed controller joins the switch. I will wait for anyone else on the ruckus forums to chime in 
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes
I see. I tried that. that did not work also. i will try a reset right now and get back to you.
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes
How do i factory reset? just press the reset button once or do i hold and release it for a certain amount of time? appreciate the help
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes
Hi again. Can you give me some guidance on what wires to replace from this picture?
Thanks for your help.
Photo of hayk

hayk

  • 387 Posts
  • 59 Reply Likes
Ok here's the thing.. have you tried going back to unleashed 200.6.10.1.312??? note doing this will reset all settings.. and you can not import later settings from newer firmware.
Photo of hayk

hayk

  • 387 Posts
  • 59 Reply Likes
how many times a day do you lose a heartbeat? I noticed I've been losing it twice a day.
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes
MULTIPLE TIMES! its annoying and i am doing stuff for work and it disconnects. Probably once every hour. 
Photo of Pieter Schepens

Pieter Schepens

  • 16 Posts
  • 1 Reply Like
Have you tried a factory reset of the AP's? I also experienced heartbeat loss, kernel panic, reboots, ... and tried upgrading, downgrading, ... Nothing helped, until I did a factory reset on an AP: problems gone. Worth trying on one AP and observing how that plays out.

Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes
Lets see if it helps. Is it possible the issue could be my router?
Photo of Andrew Giancola

Andrew Giancola

  • 187 Posts
  • 61 Reply Likes
 I am hoping the heartbeat and the WiFi performance bits are not related. If I were testing this, and attempting to get to the bottom of the issue, I would plug a device into the CP12, and likely use PingPlotter and try to monitor three distinct points in the network.
  1. ping from the device to the CP12's IP address
  2. ping from the device to a non-sleeping client on the wifi (this can be tricky)
  3. ping from the device to each of the APs
  4. ping the "gateway"
  5. ping the wan Gateway
With Ping Plotter, you'll soon get graphs relating to the interrupts. With this data, you should be able to cross-reference missed ping events against the "heart Beat Lost" messages, and the graphs will give you a visual way to see which devices are affected.

Also, has your Wi-Fi dropped since you made the settings change? 
Photo of AmaF

AmaF

  • 24 Posts
  • 2 Reply Likes
@Andrew Giancola
So I took your advice to change the following settings:
Services>Radio Control> Back Ground Scanning
Uncheck the options, or set them out further like 9000 seconds.

I can say I have not got any heartbeat loss for a couple of days! So it seems to change the background scanning to 9000 has been successful so far. I will keep monitoring it but before I was getting heartbeat loss every hours/2 hours but I have not experienced it for a couple of days as of yet. 

Do you still suggest I do the ping tests you referenced in your last post?
I really appreciate your help.
Photo of Andrew Giancola

Andrew Giancola

  • 187 Posts
  • 61 Reply Likes
@AmaF, So Changing Background Scanning did the trick? How are things today? Excited for you!
Photo of Chris Apostolof

Chris Apostolof

  • 1 Post
  • 0 Reply Likes
So so so glad I found this thread. I’ve been rebooting 3-4 times a day on r710’s. Let’s see how we do tomorrow!
Photo of Chris Nicholson

Chris Nicholson

  • 24 Posts
  • 8 Reply Likes
I down graded my home AP to standalone firmware. Works like it should... nothing disconnects. I have all sorts of devices across 2.4 and 5. Guess I am back to "ZD or Standalone."