Ruckus Unleashed r500 not working correctly with Google Expeditions

  • 1
  • Question
  • Updated 4 months ago
  • Answered
I have a client who has just half a dozen unleashed r500 Ap's all on the same subnet.
All they want to do is be able to use Google Expeditions so that one ipad can be a Guide and the others as Followers.
The ipads all receive their ip addresses from same DHCP server and all on the same subnet- they are set up on the Master AP as VLAN 1 there are no other VLANs .
The Google Expeditions apps cannot find each other -the idea is that they are all on same wifi network -once the Leader has started the app the followers can find the leader , form an expedition and get exploring.However neither can find each other.
Everything I have read around this advises me to tick the bonjour gateway tick box and allow this between VLANs - however I have been advised that because they have a flat network with no VLANS Bonjour Gateway is not relevant as all broadcast traffic is on the same subnet, so it should just work straight away. The trouble is it doesnt.

Im hoping some /many of you will have experienced this before.
Many thanks in advance
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 1848 Posts
  • 266 Reply Likes
Hello Goodday,

Thanks for describing the expected behavior of the app.  It sounds like it's Multicast based.
Ruckus has a Directed Multicast feature, enabled by default, that will give first 5 multicast
members a TCP rather than UDP message, with better delivery expectations.  But in the
case of roaming clients, it sounds like you want this feature to be disabled and we let IGMP
work and flood AP WLANs with client multicasts.

The key is to determine which WLAN interface your Google clients are using, then tell all the
APs to disable the directed multicast feature.  I'll show you how to get this information from
SSH to a Member AP, and the Master AP.

Say your clients are on my WLAN with SSID = SRO-mic.bra-Unl-PSK.  We need to know
what WLAN ID is associated with this SSID, on both radio bands of your APs.  Once we
have this wlanX, we can send a command to all APs thru the Master AP, that they should
disable directed multicast on this SSID, on both radios.

Member AP:
SSH to any Member AP, login with Admin uid/pw:
rkscli:
rkscli:  get wlanlist
Name  Status  Type  wlanID   RadioID   bssid      ssid
wlan0      up       AP    wlan0          0       <mac>   SRO-mic.bra-Unl-PSK
wlan1      up       AP    wlan1          0      <mac>    Test-guest-access

wlan32    up       AP    wlan32        1       <mac>    SRO-mic.bra-Unl-PSK
wlan33    up       AP    wlan33        1       <mac>    Test-guest-access


Master AP:
SSH to your Master AP, login with Admin uid/pw:
>  en
ruckus#  debug
ruckus (debug): remote_ap_cli -A "set qos wlan0 directed multicast disable"
....
ruckus (debug): remote_ap_cli -A "set qos wlan32 directed multicast disable"
...
ruckus (debug): quit
ruckus#  quit
Photo of Michael Brado

Michael Brado, Official Rep

  • 1848 Posts
  • 266 Reply Likes
I've filed UN-850 Unleashed feature request to have Directed Multicast control added under Edit WLAN, advanced options, either 'Access Control' or 'Other'.
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Thank you very much for taking the time to suggest a solution and for the feature request. I have implemented this tonight and will check it tomorrow . Brilliant!!
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Just to update that my client attempted to use google expeditions today after applying all the changes and it is still not working the devices can not see each other on expeditions. If you could help any further i would be very grateful.
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Can i just add please - should i be typing a different et of commands. My clients network is Ruckus Unleashed and doesnt have a zone director. However the commands above have not worked. On another part of the forums someone has posted the following as a resolution to turn off directed multicast and I wondered if i should do it.

Here are their commands

ruckus> enable
ruckus# config
ruckus(config)# show wlan (to get the exact name of the WLAN I wanted to configure)
ruckus(config)# wlan MySSID
ruckus(config-wlan)# no qos directed-multicast
ruckus(config-wlan)# qos directed-threshold 0
ruckus(config-wlan)# end
ruckus(config)# end
ruckus# reboot

Are these valid commands for the unleashed system -where do i apply these commands onto the master ap or individually on each ap. Will this definitely work to allow Google Expeditions through.

Many thanks in advance
Photo of Michael Brado

Michael Brado, Official Rep

  • 1848 Posts
  • 266 Reply Likes
Goodday,

    Yes, the above (commands from a ZoneDirector WLAN edit), also work under your Master AP,
and is an alternative to the Member AP/Master AP CLI commands I provided above.  Please try
this out and let us know your results.  I'd never heard of "google expedition" until you asked, so I
do not know all it's underlying protocols, thanks.
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Thank you I'll try it. Do I need to undo the commands you gave me yesterday or will this not affect them. If I do need to undo them how do I do that ?
Photo of Michael Brado

Michael Brado, Official Rep

  • 1848 Posts
  • 266 Reply Likes
Hello Goodday,
    While a google page tells people to use iPhones/Androids and create tethered HotSpots
for peer-to-peer communication, a normal WiFi network *should* work if you haven't enabled
any type of wireless client isolation (clients on same AP wlan).  Check your Networks, edit
WLAN, advanced options, Others page to be sure no check for Client isolation on AP or LAN.
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Thank you I have been working from same page. Wireless client isolation is untucked on that page. Hotspots is a short term fix but only supports up to 5 clients apparently and they need 30 connected and would prefer it to be through ruckus.

Do I need to undo yesterday's commands do you think ?
Just to say I really do appreciate your support
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Unticked on that page it should say
Photo of Michael Brado

Michael Brado, Official Rep

  • 1848 Posts
  • 266 Reply Likes
Hi Goodday,

    We released Unleashed 200.3.9.13.228 yesterday.  You're using regular WPA2 PSK WLAN,
but find 5 clients on a HotSpot WLAN could communicate?  Could you get a change management
in order to perform an upgrade to your network and re-evaluate?  I would like to know if you see
a fix.
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Hi Michael
Thak you for your advice - before i try the 200.3.9.13.228 I cant get these two lines to work from the code i include a few posts back .

ruckus(config)# show wlan (to get the exact name of the WLAN I wanted to configure)
ruckus(config)# wlan MySSID

when i type show wlan - i receive the ssid as xxxxxxxx Wi-Fi ( the x's represent the network name followed by a space then Wi-Fi

However if i then type wlan xxxxxxxx Wi-Fi instead of where it says MySSID above i always receive the error "the command is either unrecognised or incomplete"

Can you advise where i am going wrong - there is deifinitely a space between the network name and Wi-Fi but it doesnt make any difference if i include or exclud this space it still throws an error.

In respect of you 200.3.9.13.228 firmware upgrade -because i am not on site can you confirm that this will not wipe any settings or need any configiration afterwards please.

I can confirm that at the end of last week i visited the site and got google expeditions working with 3 ipads and an iphone hotspot and it is wpa2 encryption.

Look forward to hearing from you
Photo of goodday1

goodday1

  • 11 Posts
  • 0 Reply Likes
Hello just wondered if anyone could help with my problem above please.