Ruckus R710 APs on HP Procurve 3500yl (J9310A) PoE+ switch

  • 1
  • Question
  • Updated 2 years ago
This took a bit to find the clues scattered across the Internet. I am putting this here to help others who are on the hunt to get their HP Procurve PoE+ switches working with the new Ruckus R710 AP (in 802.3at mode). I tested this method on the HP Procurve 3500yl (J9310A) PoE+ switch. It may work on other HP Procurve models.

First, there are settings that need to be done in the ZoneDirector to enable LLDP. If you are using the APs as standalone devices, you may need to enable LLDP on each AP. 

1. Connect to the ZoneDirector using Telnet or SSH.
2. Enter the following commands:
    enable
    config
    ap-group "System Default"
         LLDP enable
    exit
    (REPEAT the ap-group part for each ap group you have setup in ZoneDirector)
    exit
3. Connect to the Procurve 3500yl (J9310A) switch using Telnet or SSH.
4. Check the switch firmware. It should be K.16.01.0004 or newer.  If it is older, update the firmware on the switch before continuing.
5. Enter the following command to check the firmware version:    
    show version
6. Determine the ports you have the R710 APs connected to. (I have ports 1-10 are connected to Ruckus R710 APs)
    Use this command to 'see' the PoE devices on your switch:
    show power-over-ethernet brief
7. Enter the following commands:    
    config
    lldp run
    interface 1
       poe-value 25
       poe-lldp-detect enable
    exit
    (REPEAT for each interface that has a Ruckus R710 AP connected)
    lldp config 1-10 medTlvEnable capabilities
    lldp config 1-10 medTlvEnable network_policy
    lldp config 1-10 medTlvEnable poe
    lldp config 1-10 dot3TlvEnable poeplus_config
    exit
    write memory
8. Reset power to APs (this will disconnect anyone using WiFi momentarily)
    config
   interface 1
       no power
      power    exit
     (REPEAT for each interface that has a Ruckus R710 AP connected)

Sit back and relax. After some time has passed, check the ZoneDirector -> Monitor -> Access Points -> click on one of the R710 APs and see that it shows 802.3at PoE+ for "Power Consumption Mode"

This worked for me!     
Photo of Randy Prothero

Randy Prothero

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2183 Posts
  • 301 Reply Likes
Thanks Randy, your details will become a Knowledge Base Article.
(Edited)