Ruckus IOT suite & philips HUE lights and motion sensor

  • 1
  • Question
  • Updated 3 months ago
  • Acknowledged
  • (Edited)
i am currently working on a project that involves pairing hue motion sensors,lights,smartplugs and ledstrips to the ruckus iot controller, but i have been stuck on how to make the light turn on or change brightness or colour when for example the sensor picks up motion. I have been trying to use node-RED for this but i havent had any succes yet. Anyone that could offer some help or advice here? to me it seems like i would need a hue bridge but doesnt the RIOT controller fulfill that purpose?
Photo of laurens Puystjens

laurens Puystjens

  • 6 Posts
  • 0 Reply Likes
  • stuck

Posted 4 months ago

  • 1
Photo of laurens Puystjens

laurens Puystjens

  • 6 Posts
  • 0 Reply Likes
So i am really stuck trying to pair a motion sensor to a smart bulb both registered with the Ruckus IOT controller. i keep running into dead ends, is there anyone that could help with this case?
Photo of laurens Puystjens

laurens Puystjens

  • 6 Posts
  • 0 Reply Likes
so i managed to get the access token from the IoT API of the controller with node-RED, but whenever i use this token with an authorization header i'm getting this error: detail: "Authentication credentials were not provided." anyone that has encountered this problem with the API as well?
Photo of Michael Brado

Michael Brado, Official Rep

  • 2923 Posts
  • 407 Reply Likes
I have a contact who might be able help you Laurens.  He knows the IoT controller side, and about the two tokens with Philips HUE lights.
Which make/model of motion sensor do you have?  (Philips doesn't make them)
I'm getting his contact information.
(Edited)
Photo of laurens Puystjens

laurens Puystjens

  • 6 Posts
  • 0 Reply Likes
my current problem is the motion sensor, its an osram smart+ motion sensor. I can turn the lights (i have switched to also osram lightbulbs) on and off through node-RED without much problems. But this motion sensor i have i cannot seem to get the motion state for it through the ruckus API. i have tried disconnecting and reconnecting it to the controller and the entire device attributes changed too(device type changed from IAS zone device to simple sensor for some reason). im currently waiting for another motion sensor to test with.
i also would like to mention that i am a total novice when it comes to this. and thank you for your reply, any feedback/help with this project is really appreciated!
(Edited)
Photo of laurens Puystjens

laurens Puystjens

  • 6 Posts
  • 0 Reply Likes
I've solved it, the first motion sensor i was working with was faulty, now that i have a working one everything runs without a problem. 
Photo of laurens Puystjens

laurens Puystjens

  • 6 Posts
  • 0 Reply Likes
after a few days of testing i noticed that the ruckus IOT controller loses connection with some of the IoT end devices, for example i cant turn my light bulbs on or off via the controller. The motion sensor on the other hand responds fine.
the first time this happened all of the devices didnt respond anymore and i fixed the problem by unplugging the iot module from the AP and re inserting in. yet this doesnt solve anything anymore.
Anyone knows why and how this problem keeps reoccuring?