Ruckus IoT controller DHCP Option Question

  • 1
  • Question
  • Updated 3 weeks ago
  • Acknowledged
So I understand how the Option 43 works well for the VSZ and ZD.  However for the IoT controller documentation seems to be a bit confusing.  It says that the IoT controller uses option 43 and suboption 21.  I have tried a few different scenarios but no luck. 
Photo of Ali

Ali

  • 29 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2848 Posts
  • 399 Reply Likes
Hi Ali,
   The IoT Getting Started Guide says DHCP Option 43 is used to direct APs to the controller.
https://support.ruckuswireless.com/documents/2460-ruckus-iot-suite-getting-started-guide-gsg

    We have a number of knowledge base articles on how to configure DHCP option 43 on different
server platforms.
https://support.ruckuswireless.com/articles?article_id=&query=option+43

    I hope this is helpful.
Photo of Ali

Ali

  • 29 Posts
  • 0 Reply Likes
Thank you Michael, so I already know how to configure DHCP Option 43 and no issues there.  I'm having some trouble with the DHCP Option 43 with Sub Option 21 for IoT controller.
Normally Option 43 would be:
06:XX = Length of the IP:Rest of the Hex
Where 06 is the Sub Option

Now if I have to do the same for VSZ and IoT what would be the format?  Would it be something like below?

06:XX:Rest of the Hex:15:XX:Rest of the Hex

06 = Suboption for VSZ
XX = Length of the IP

Photo of Michael Brado

Michael Brado, Official Rep

  • 2848 Posts
  • 399 Reply Likes
Sub option 21 (hex 15) holds the IoT Controller IP address in ASCII mode. This value is used (if IoT Service is started on the AP) to connect to IoT Controller.

It starts with length of the value, followed by the value (exactly the same way, how the sub options 3 and 6 is configured on the DHCP server).

 
(Edited)
Photo of Ali

Ali

  • 29 Posts
  • 0 Reply Likes
I have tried this on multiple devices Meraki Firewall DHCP and Cisco ios DHCP using IP and HEX multiple combinations and nothing works.  Even if I manually start the service on the access point (which I shouldn't have to because that does not make sense, if I am deploying 100 AP's I will have to log into each AP and start the service?) it goes to the default server vriot.ruckuswireless.com

Links you suggested all talk about really DHCP Option 43 with ZD or SCG config and that part I already works.

Question is, how to add the DHCP sub option 21 so this works?  Still testing and trying to find an asnwer

Thank you.
Photo of Ali

Ali

  • 29 Posts
  • 0 Reply Likes
Thank you so I have started iot service on the AP by "iotg start" and it shows the MQTT broker IP as vriot.ruckuswireless.com

I am using a Meraki device as a DHCP and I have simply specified Option 43 and then Option 21 with the IP of the IoT controller now as apposed to using the full HEX values previously for VSZ and IoT controller but same results.

Also looks like every time AP reboots we have to restart the iot service with "iotg start" command?

Photo of Ali

Ali

  • 29 Posts
  • 0 Reply Likes
Here is a DHCP discover from the 730.  I don't even see it requesting 21.
(Edited)