Ruckus AP with multi SSID into ICX Switch

  • 1
  • Question
  • Updated 10 months ago
Longtime user of Ruckus AP's, but new to the ICX switches.  I've been using the ICX Switches in test-bench scenarios to see how I like them before deploying them wide spread.  I apologize for what may seem a simple question, but I am just not getting this to work.

I have a single ruckus AP, 510 Unleashed, and they have two SSID's tagged on two separate VLAN's, so within the AP Test1 tagged on VLAN 1, and Test2 tagged on VLAN 2.

I'm currently using a 12 port ICX 7150 switch.  My gateway is feeding into port 1/2/1 on the switch, and my AP is plugged into 1/1/11.  I have my Management VLAN as 10, and I have VLAN 1 & VLAN 2 by port set up.  

In the Switch both VLAN 1 & 2 have 1/1/11 Tagged and 1/1/11 is set to dual-mode, and inline power is enabled.  VLAN 1 & 2 also both have 1/2/1 tagged, and it is also set to dual-mode.

When connecting wirelessly, SSID Test1 works great and I pull IP information, but Test2 does not seem to be passing info back to the gateway, as I do not properly pull an IP.

I can see the gateway from any computer plugged into an untagged port associated with either vlan.  

I have set this same function up on other switches (though I'm not as proficient with CLI - I'm trying to get better), so I'm sure it's possible.  

What am I missing?  I feel like I'm super close to figuring this out.  Thanks!
Photo of KC Luchsinger

KC Luchsinger

  • 9 Posts
  • 1 Reply Like

Posted 10 months ago

  • 1
Photo of Sandeep Gupta

Sandeep Gupta, Employee

  • 28 Posts
  • 12 Reply Likes
Does your gateway device understand 802.1q tags?  it may be simply dropping the packets coming from 1/2/1 since it doesn't know what to do with them.
If you do have your gateway device interface enabled with VLAN2 then it should respond to clients on that VLAN asking for an IP, and passing packets, etc. (again assuming the VLAN2 details have been set up correcty like dhcp scope).

If your gateway device does not do VLAN tagging then you would have to use routing on the ICX switch to make this whole thing work.  Enabling inter-vlan routing is as simple as:
1. running router code image on the switch
2. creating an interface (ve) on each vlan
3. using that interface as the router IP (default gateway)

What kind of gateway device are you using?
Photo of KC Luchsinger

KC Luchsinger

  • 9 Posts
  • 1 Reply Like
Thanks for the reply!  My gateway does indeed understand tagging.  I have it set up for egress tagging on both VLAN's.  As I mentioned, I have done this exact same setup before, the switch being the only thing that's different.  I do have inter-vlan routing already set up on the Gateway
Photo of Sandeep Gupta

Sandeep Gupta, Employee

  • 28 Posts
  • 12 Reply Likes
If its tagged all the way through, should just work.  You could validate by removing the dual-mode and ensuring VLAN1 still works as well.
Might want management VLAN 10 as the untagged/dual-mode VLAN with all others tagged.

Also sometimes with VLAN1 being the 'default-VLAN-id' things get wonky though in your case thats the one that's working.  I might suggest you use 2 VLANs other than #1 for your setup OR change the default-vlan-id configuration on the switch to something other than 1.

You're pretty much connecting two devices, the gateway and the AP, through the switch with both ports tagged.  Right? so perhaps the AP setup is incorrect and its not tagging the VLAN2 stuff?  not sure, you're likely missing something simple..  could warrant a call to Ruckus TAC to help diagnose what you're missing.
Photo of KC Luchsinger

KC Luchsinger

  • 9 Posts
  • 1 Reply Like
I did change my default VLAN to 10, as stated in the original posting, as I did run into that as being a barrier for configuration, so that's a valid suggestion, but one that has already been eliminated.

When I first set this up, I did it without Dual-mode on and just did one SSID to make sure everything was passing, then set the second one up, switched to dual mode, and replicated my success on SSID1.  

Yes.  Port 1/2/1 from the Gateway is tagged, and port 1/1/11 from the AP is tagged.  

I also believe that I am missing something on a very basic level.  That's what's confusing me.
Photo of KC Luchsinger

KC Luchsinger

  • 9 Posts
  • 1 Reply Like
After a little work this afternoon, I just factory defaulted the WAP and set it up fresh again.  Maybe I had old settings in there from another test or something because it connected right up with the config I had.  Thanks for the help!