Ruckus AP R500 with 104.0.0.0.1347 and ZD3050 with 9.8.3.0 Build 58

  • 1
  • Question
  • Updated 2 weeks ago
We have a ZD3050 with firmware 9.8.3.0 build 58 and recently purchased 40 R500 AP's with firmware 104.0.0.0.1347 but the AP's are refusing the firmware downgrade. Any idea on how to create a working situation? Upgrading the ZD is not an option since we still have more the 150 7962 AP's...
Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes

Posted 3 weeks ago

  • 1
Photo of Fabian Garzon Baquero

Fabian Garzon Baquero, Employee

  • 3 Posts
  • 2 Reply Likes
Marius,


If you need to remain in that version because of the 7962 Aps, you must downgrade the R500 APs to previous standalone version, 


Here is the link to download the firmware:

https://support.ruckuswireless.com/software/793-standalone-ap-software-9-8-3-0-14-all-aps


After the downgrade, you will be able to manage the R500 Aps in ZD controller with the mentioned version.

Regards,


FABIAN GARZON
Principal Technical Support Engineer
Photo of abi

abi

  • 24 Posts
  • 3 Reply Likes
Hi Marius,

Please upgrade one of the AP with 100.x firmware and try to connect them with ZD, else enable FTP server on ZD and download 9.8 firmware for R500 from ZD and update the AP, now the AP should connect to ZD with 9.8 firmware.

If you still find issue Please contact support.

Thank you,
Regards
Abilash PR.
Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes
Hi, thanks for the quick response...
I have downloaded the firmware 9.8.3.0 build 14 specifically for R500, the firmware copied to a laptop, the laptop configured with 192.168.0.10 and AP with utp connected to this very laptop. In the browser the AP addressed on 192.168.0.1 and the firmware upgrade started, however after finishing the upgrade the AP reports "Great. I'm all done" but still 104.xxxx firmware is present and not the expected 9.8 firmware!!!!
Photo of abi

abi

  • 24 Posts
  • 3 Reply Likes
Hi Marius,

Please ssh into the AP, and run command "fw show all" please check if 9.8.3 been updated to one of it's boot memory. If it has, please try to update again.

Please run comman "set director ip " and "reboot".

Please paste output of "fw show all" and "get log syslog" below if issue persists.

Regards,
Abilash PR
Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes
rkscli: fw show all
<Control Info>
control file /writable/fw/main.cntl not in flash
-------------------------------------
current primary boot image is Image2
---------------<Image1 FW header>
Magic:        RCKS
next_image:   0x130000
invalid:      0
hdr_len:      160
compression:  l7
load_address: 0x80080000
entry_point:  0x802FF060
timestamp:    Fri Aug 19 08:57:32 2016
binl7_len:    9975644
hdr_version:  4
hdr_cksum:    0x0105
version:      104.0.0.0.1347    ( 104.0.0.0.1347 )
MD5:          81E160C70589AA24D7A5BC85A27A10C5
product:      zf7752    (0)
architecture: 1
chipset:      3
board_type:   0
board_class:  3
customer:
Image Sign Type: Intermediate Signed Image(ISI).
Tail start:   0x982f60
---------------<Image2 FW header>
Magic:        RCKS
next_image:   0x130000
invalid:      0
hdr_len:      160
compression:  l7
load_address: 0x80080000
entry_point:  0x802EF840
timestamp:    Wed Jul 22 05:19:27 2015
binl7_len:    10055520
hdr_version:  3
hdr_cksum:    0xD20B
version:      9.8.3.0.14        ( 9.8.3.0.14 )
MD5:          E1DF23D07E1E70912C0AD35BD8727D89
product:      zf7752    (0)
architecture: 1
chipset:      1
board_type:   0
board_class:  3
customer:
Image Sign Type: Unsigned Image(UI).
OK
rkscli:
rkscli: get log syslog
Command is not recognized: get log syslog

Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes
When I run the command "fw show all" I get to see indeed both firmware, the higher one resides on Image1 FW header, the second on the Image2 FW header but it says "current primary boot image is Image2" which I expect to be the 9.8.3 firmware....:(

Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes
It seems the question is how can i switch between the firmware images since both reside on the R500.....Is there a command for it?

Photo of abi

abi

  • 24 Posts
  • 3 Reply Likes
Hi Marius,

There is one but that would only work if you have Shell's access, please give a try upgrading again there is a chance of current boot image getting updated. If it fails again I would recommend you contacting support because there was a change in new R500 I coul not get that right now on my mind which would cause them not to upgrade to older versions, please isolate if that is was we are seeing.

Thank you.

Regards,
Abilash PR.
Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes
Have you seen above the " fw show all" output? One image is unsigned....
Photo of abi

abi

  • 24 Posts
  • 3 Reply Likes
Hi Marius,

That shouldn't cause a problem, please try "get syslog log" it should shed some information for this behavior.

Regards,
Abilash PR.
Photo of Dan Edwards

Dan Edwards

  • 2 Posts
  • 0 Reply Likes
Having exactly the same issue here too Marius, have you found a solution yet?

Thanks
Dan
Photo of Marius Negrea

Marius Negrea

  • 10 Posts
  • 0 Reply Likes
Well, a long story short: the latest batches R500's contain a different chip inside which is not compatible with firmware 9.8.3.0 build 58. In my case  i was fortunate enough to have an extra ZD3050 as spare which I upgraded to 9.10.2.0 build 63 at which point the AP's behaved normally towards the ZD (firmware was downgraded to the firmware of the ZD).
Now I will open a ticket just to find out weather exist any AP's compatible with 9.8.3.0build58 because R500's are surely not...
Photo of abi

abi

  • 24 Posts
  • 3 Reply Likes
Hi Marius,

Please download latest software release notes of build 9.8.3.0.58 all APs mentioned in it are supported that should resolve your qurey or answer all queries and further if needed please open a support ticket with more quries. This is something peculiar to R500s that to a batch with certain serial numbers; more information can be got through support ticket.

Thank you.

Regards,
Abilash PR.
Photo of Dan Edwards

Dan Edwards

  • 2 Posts
  • 0 Reply Likes
Can confirm that 9.9.x also does not work but will give 9.10 a go and hopefully that will solve my issue too. Already had 6 R500's working fine (although did previously have a batch of 2 that came with newer firmware that required manually downgrading first but that time it worked...) and release notes still say they are supported as far as I can tell.

Was able to manually downgrade to 100.x firmware on the R500 but then when trying to downgrade further received an error that the image headers were invalid - same image that appeared to downgrade fine when on the original 104.x image
(Edited)
Photo of 1Said Sanoussi

1Said Sanoussi

  • 2 Posts
  • 0 Reply Likes
Hi all,

Recently ran into the same issue. ALL R500, R600, T300 and T301 ap's with a serialnumber starting with 4717xxx and later. Which means they are manufactured from 2017 and later hhave this issue due to the flashchip that is built in the AP. The ZD FW needs to be 9.10 or higher for this to work. All ap's before 2017 will work fine. No workarroud or patch is available for this. Hope this info helps