Root-APs thinks he's a Mesh-AP resulting in Network Issues

  • 1
  • Question
  • Updated 8 months ago
  • Answered
  • (Edited)
Hello everyone,

yesterday i was on a customer site because of some network issues.
From time to time i lost 1 - 3 Pings within the whole Network.
I searched for the error an saw that a Switch Port with one of my Ruckus APs (T300) attached seems to be the bad guy.

I saw the AP was listed as a Mesh AP. But it has a cable Connection and should have been a Root-AP.
After configuring the AP to be a Root-AP with AP-Group Settings, network was stable again.

Any ideas?
Should i generally configure the Mesh-Mode (Root or Mesh AP) within my AP Group instead of leave the default Mode "Auto" to prevent this?

Please give any Feedback and/or experience.
Thanks!

Kind Regards
Marco
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes

Posted 9 months ago

  • 1
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes
Additional Information:
I saw that the Network Port on the Switch was offline about 20 Seconds. Within this time the Ruckus AP searched for an alternative way. After the Network Port was back online again the AP did not changed from Mesh AP to Root AP and the "party" started. ;)
Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 759 Posts
  • 162 Reply Likes
marco

switch port being up is not the right metric however you need to see if reachablilty back to controller is good and how good it is compared to the RF route picked by the AP when wired route was out,
also look at negotiation setting which should be set to default setting..
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes
The AP was able to reach the controller without any issues (from Switch Perspective).
It is a 1Gbit/s cabled Network.
No other Devices on this Switch had any issues. I am monitoring the reachability of my controller and all of my Switches. No Outage. They had no issues. There where no connectivity Problems to the Controller. All other APs also had no connectity issues.

After i found the problematic Switch Port with the AP attached i disabled the Port. The Network was stable again. After enabling the Port, Network Problems came back again.

Disabling or Enabling the Switch Port did not changed the Mesh Mode of the AP.
APs was listed still as a Mesh-AP within my ZD GUI.
After restarting the AP the AP was listed as Root-AP again and my issues were gone.

Sure i think the Switch Port had an Problem. There must be a Reason, why the Port was offline for about 20 Seconds. This is because the AP looked for an alternative Route.
But the AP did not changed his Mesh State after the Port was online again. Disabling/Enabling the Port did also solve nothing. Only the Restart of the AP solved my issue.
So i asked me if this behavior is a bug, by design or just a faulty configuration from my side. I thought AP should switch to Root-AP Mode back if the Network Connection is restored.

Maybe there are things like Reccomendation using Manual Mesh Settings, Disabling RSTP on Switch, Known Bug, etc.
(Edited)
Photo of Alan Rothenstreich

Alan Rothenstreich

  • 63 Posts
  • 11 Reply Likes
Once an AP meshes, my experience is that it will stay meshed since it will see an internet connection.  If your AP is hardwired I suggest disabling mesh on that specific AP.  Once you change the setting, the AP will restart and will only connect over the Ethernet.
Photo of Marco Eichstetter

Marco Eichstetter

  • 148 Posts
  • 7 Reply Likes
Hi Alan,

the AP meshed (don't know why. no other Network Device on that Switch had any issues). But after a working Internet Connection (and Connection to the Controller) was definitly there, he still meshed.
So like you wrote i disabled Mesh for my wired APs and the APs restartet. After that the Problem was gone.

I think i will change my Mesh Setups in the future.
I will configure my APs as Root or Mesh AP and don't use the default Mesh Mode "Auto".

Thanks.
Marco
(Edited)
Photo of Alan Rothenstreich

Alan Rothenstreich

  • 63 Posts
  • 11 Reply Likes
Glad to hear you have everything working.  Unfortunately, the AP connects to the first connection the AP sees.  It might be a timing issue on the switch.  My recommendation is to do what you said, disable the meshing or set wired APs as root only on a per AP basis.  I usually recommend you at least have mesh enabled on the controller, in case you need it in the future.  It proves helpful when you have a cable issue and need to restore a client quickly.

Alan
Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 759 Posts
  • 162 Reply Likes
as a side note, if you are keen to know why it is really happening then you should look into the AP support file of the problematic AP to see MESH logs on