Radius Proxy on vSZ

  • 1
  • Question
  • Updated 1 year ago
Hi Everyone,

I have setup a WLAN with a WISPr profile (external Portal).
I am currently redirected correctly to the captive portal, however I cannot authenticate because the my Radius Server is not reachable from my vSZ which is acting as a Radius Proxy for the auth requests.
I would like to know if it is possible to make the APs authenticate the user directly without going through the vSZ.

PS: I have configured the Radius server on the WLAN configuration and unchecked the "use the controller as a proxy" in the WLAN configuration

Thank you in advance
Photo of Othmane Douiri

Othmane Douiri

  • 9 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Stuart Wren

Stuart Wren

  • 1 Post
  • 0 Reply Likes
Version 3.2 of the SmartZone has a Non-Proxy AAA mode where the AP's can talk directly to the RADIUS server. In previous versions it is also possible to allow the AP's to use AAA as I have done this. What version of the vSZ are you using?
Photo of Renars Briks-Dravnieks

Renars Briks-Dravnieks

  • 2 Posts
  • 0 Reply Likes

I have added RADIUS proxy server under Configuration-> Services&Profiles->Services-> Authentication
But I am not seeing it under APzone->WLAN-> WLAN configuration->Authentication Service: It is simply not showing up there. Have I missed something?
Under APzone->AAA I can create non-proxy mode RADIUS and thats shows up correctly, but I want to use proxy mode RADIUS.

I use vSZ-H v3.2.1.0.193
Thanks in advance for hints.

Photo of Renars Briks-Dravnieks

Renars Briks-Dravnieks

  • 2 Posts
  • 0 Reply Likes

Have not tested yet, but here is how to do it:

Here's what you need to do to map the authentication service for RADIUS proxy mode:

Login to vSZ-H >>Configuration >>Services & profiles >>Under >>service profile >>Authentication>>You have to create a profile: Give profile Name >>Clicked on "No match ">>select authentication service (proxy mode server) which you have created under Services>>Authentication, kindly map it >>Select auth method >>Non-3Gpp call Flow >>click apply.
Repeat same for Unspecified:
Click on Unspecified >>Select the service as your Authentication profileĀ  >>choose Non-3gpp call flow >>Click apply..

Now go to AP zones >> WLAN >> edit WLAN configuration for which You need to use RADIUS proxy server >> under Authentication Service select checkbox: Use the controller as a proxy and You should be able to choose profile You created above.

Hope this helps.