R710: "PoE+" injector still gets recognized as 802.3af power

  • 1
  • Question
  • Updated 5 months ago
  • Answered
For fun, I tried buying a PoE+ injector to unlock full transmit power on 2.4GHz on my R710. I found that even with an injector that's advertised to be PoE+, the power mode still says 802.3af, not 802.3at.

Looking at the support article KB-5005, it looks like it's implying that PoE+ negotiation requires a PoE+ switch that speaks LLDP. Is this true? Is there any way to get the AP into PoE+ mode via an injector?

https://support.ruckuswireless.com/answers/000005005
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes

Posted 2 years ago

  • 1
Photo of hayk

hayk

  • 19 Posts
  • 3 Reply Likes
isn't LLDP the function of the switch that you are hooking it up to while using the injector?
(Edited)
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Yes and no -- LLDP in this context refers to the LLDP POE+ switch negotiation protocol. since my underlying switch isn't PoE, the switch isn't going to speak it. And my injector is too dumb to speak LLDP too.
Photo of hayk

hayk

  • 19 Posts
  • 3 Reply Likes
oh I see the issue now....
Photo of Brian Hoyt

Brian Hoyt

  • 46 Posts
  • 3 Reply Likes
Was there ever an answer to this? I too have a handful of R710 and would like to get injectors rather than whole new switch if possible.
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
In 9.13 ZD and I presume the corresponding SZ release, there's now a controller-wide POE mode option under the AP config that allows you to specify at, which forces PoE+ (suitable for injectors).


Works well for me on R710 / ZD 9.13 GA


Quite honestly though, in retrospect this wasn't worth all the effort / fretting anyway. I honestly don't notice much of a range or performance difference on the 2.4 radio. IMO this AP seems just as performant in AT or AF mode.
(Edited)
Photo of Brian Hoyt

Brian Hoyt

  • 46 Posts
  • 3 Reply Likes
Using 9.13 and a Netgear switch forcing it worked, but you are probably right, big deal?
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
It seems like also, 9.13 switched the behavior of af fallback from reducing 2.4GHz tx power to reducing to 4x2 MIMO, which seems like it would have even *less* of an impact on observable performance.

The only devices I have capable of 3ss on 2.4GHz are always on 5GHz anyway.
Photo of Vito

Vito

  • 2 Posts
  • 1 Reply Like

I'm surprised the answer isn't mentioned here, and I couldn't find it on the link above at Ruckus Wireless support, although that helped point me in the right direction. 

You shouldn't need to use a POE+ switch with LLDP if you have a POE+ (802.3at) compatible power injector.  You need to connect to the R710 access point's CLI (command line interface) via SSH (putty.exe on TCP port 22) and type the following:

rkscli: set power-mode at

Then type:

rkscli: get power-mode

and it should show:

PoE Configured Mode      : AT
Power Consumption Status : 802.3at PoE+
OK

Hope this helps!

Photo of hayk

hayk

  • 19 Posts
  • 3 Reply Likes
Thanks Vito,

    I was about to give up on this and now it works fine in AT mode :)
(Edited)
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Beware that setting this option via AP CLI may not persist past reboot. This setting is now on the controller side too -- go to Configure -> AP and select the AP. There will be a Power Mode drop down and you can force to AT from there.

Not sure where the setting is in SmartZone.
Photo of Vito

Vito

  • 2 Posts
  • 1 Reply Like
This post references setting the POE/POE+ mode on a stand-alone AP, therefore setting the option via an AP's CLI may not stay as set (configured) if the AP is connected to and controlled by a ZoneDirector appliance, and your additional comment about where to set it via the ZD appliance's configuration is helpful.
Photo of John D

John D, AlphaDog

  • 497 Posts
  • 136 Reply Likes
Actually I think I made the post and was ZD managing my R710 at the time ;)

It was because Ruckus's KBAs only offered AP CLI commands which, at the time, were required to enable AT autonegotiation.
Photo of pete.braham

pete.braham

  • 1 Post
  • 0 Reply Likes
Is the AT power mode setting on the R710 CLI persistent after reboot on a stand alone AP?