R700 not showing on ZD1200

  • 1
  • Question
  • Updated 4 months ago
  • Answered
I bought two ZF R700. Software version on nr 1:"10.2.1.0.183" and nr 2: "104.0.0.0.1347"
and
I also bought a ZD1200, I upgraded that to 10.2.1.0 build 183.

I connected both trough a TP-link TL-SG108PE using PoE Power ports for the AP's and a normal one for the ZD. I factory resetted both the AP's and the ZD.


Unfortunately, I encountered two issues.

Nr 1: has been connected to the ZD shortly, then rebooted. Properly to install different firmware. Before that I had set the ip address of the zonedirector using cli (set director 192.168.178.x). All AP' s live on the same subnet (192.168.178.x).

Nr 1 shows it is managed by the ZD in the web interface, and continuesly blinks its "DIR"  light when I perform "get zonedirector", but shows either "DISCOVERY"  or "SULKING":
------ ZoneDirector Info ------
Primary Controller : 192.168.178.94
Secondary Controller : n/a
DHCP Opt43 Code : 3

The information of the most recent Zone Director:
[1] 192.168.178.94

AP is under management of ZoneDirector: 192.168.178.94 / 58:b6:33:1b:a0:80,
Currently AP is in state: DISCOVERY
OK
rkscli: get director
------ ZoneDirector Info ------
Primary Controller : 192.168.178.94
Secondary Controller : n/a
DHCP Opt43 Code : 3

The information of the most recent Zone Director:
[1] 192.168.178.94

AP is under management of ZoneDirector: 192.168.178.94 / 58:b6:33:1b:a0:80,
Currently AP is in state: SULKING
OK



I deleted NR 1 in the zonedirector after it showing "disconnected"  for a long time in the hope that would help, but no luck.

Nr 2 AP shows it being in stand-alone mode and not blinking the DIR light:
rkscli: get director
------ ZoneDirector Info ------
Primary Controller : 192.168.178.94
Secondary Controller : n/a
DHCP Opt43 Code : 3
AP is in Stand-alone mode.
OK

No AP is showing up in the Access Points tab:


I can access both AP's and the ZD from my laptop. As explained, they are both connected through the same switch. Even though, I cannot get:
nr 2 Access Point to use discovery
Nr 1 access point to be managed/connected to the ZD
Photo of Tomzooi

Tomzooi

  • 3 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 551 Posts
  • 175 Reply Likes
Hi Tomzooi,

L2 discovery seems working fine as APs are showing on ZD and same is observed on AP side.

Since AP-ZD are on same subnet, I don't think port blocking is causing this issue.

Could you try below.

1- Delete all the APs from ZD and disable the auto approval.
2- If you have configured APs IP manually, make sure gateway and subnet is configured correctly. Review the AP's IP configuration by running below command.

get ipaddr wan

3- Now login to AP manually and run below command to manually point the AP.

set director ip <ZD_IP_ADDR>
reboot

4- Check on ZD if AP is showing, if yes then click on approve (tiny green tick mark against AP entry)

5- On ZD, go to System >> Logs >> set the log level to All >> Now go to events and check what events are showing for the APs.

6- Check and make sure AP and ZD are on same country code by running below command.

get countrycode
get boarddata

Note: A country specific (Country code locked) AP will only connect to the same country code ZD. For example if you have purchased a US product code AP then ZD should also set to US country code else US product coded AP will not join the ZD.

7- On AP CLI, run below command and try to see if there is any major error which is preventing AP to join ZD.

get syslog log

Regards,
Syamantak Omer
Photo of Tomzooi

Tomzooi

  • 3 Posts
  • 0 Reply Likes
Hmm, my R700' s appear to be US based and cannot be changed...
Can I change the country code on my ZD1200? I had set it to NL, but that apparently doesn' t work...

Yes, that did the trick. I changed the country code to US on my ZD, and the AP's started discovering and upgrading. Somehow one did manage to do that apparently even though the country codes were different. Interesting, might have happened during initial setup of the ZD?

I guess there is no way I can change the Country code in my AP's to NL? I bought them from the US obviously, but they now live in Europe :-). If soldering is involved I'm up for that :-)
(Edited)
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 415 Posts
  • 136 Reply Likes
Hi Tomzooi,

Yes, AP country code cannot be changed if it's product code restricted to a specific country (in your case US).

Ruckus APs are also available in WW (World wide) code amd those APs can connect to any country code ZD/vSZ, but pricing is higher than country specific APs.

You may use the ZD as US country code while you are in NZ but it may be violation of regulatory laws, so we do not recommend this. You can use it at your own risk.

Regards,
Syamantak Omer
Photo of Anthony Rielly

Anthony Rielly

  • 22 Posts
  • 12 Reply Likes
I think it's not legal to let US owners change the country code of APs, so a vendor forum is not the right place to ask. A Google search might find something useful in GitHub.
Photo of Tomzooi

Tomzooi

  • 3 Posts
  • 0 Reply Likes
I have the second AP up and running also. It got stuck in a firmware loop at first (continually "upgrading firmware"  and " rebooting". I disabled auto-join on the ZD and factory-reset the AP. This allowed me to upgrade the AP to the latest ZF image (ZoneFlex R700 Indoor AP 104.0.0.0.1347 (GA) Software Release). After that I could allow it in the ZoneDirector. It only upgraded the firmware once and then got to work :-).

Btw, there is a small spelling error in the Software, when running " get directory", I receive:

currently AP is in state: CONFIGURAION

This appears to be similar to the state I feel in when I spend hours configuring something :-)

Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 415 Posts
  • 136 Reply Likes
Hi Tomzooi,

I am glad to know that everything is working now.

Regards,
Syamantak Omer