R700 and ZF7982 sudden reboots

  • 1
  • Question
  • Updated 2 years ago
I have 1 x ZF7982 and 2 x R700 APs all in standalone mode in 3 different locations.  They are all running version 100.1.0.0.194 and each of them will (seemingly) randomly reboot.  This occurs as often as 5 times in a day.  It occurs more often when there are many devices connected, or maybe I just notice it more then.

Currently, the log files are only saved in memory, so I don't get to see what caused the kernel panic/reboot.  But, when all devices get disconnected I'll wait a minute and connect to the admin.  Sure enough, the AP uptime and logs indicate that the device was just rebooted.

Has anyone else experienced this?
Photo of Adam Chalemian

Adam Chalemian

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of John Allmon

John Allmon

  • 1 Post
  • 0 Reply Likes
same problem.  just upgraded to 100.1.0.0.194 & started seeing the sudden reboots
Photo of Adam Chalemian

Adam Chalemian

  • 5 Posts
  • 0 Reply Likes
John, the bug is in ChannelFly while in standalone mode.  Explicitly pick channels for all of your radios in Configuration > Radio 2.4G > Common and Configuration > Radio 5G > Common.  I’m not sure when Ruckus is going to patch this, but I’ve had a 114 day uptime since disabling ChannelFly on all 3 APs in standalone mode.
Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 714 Posts
  • 151 Reply Likes
adam,

channelfy if enabled is designed to select random channel intellegently based on local RF conditions.

i have quite a few sites running on this version so would like to know how you came to know that its a bug...
Photo of Adam Chalemian

Adam Chalemian

  • 5 Posts
  • 0 Reply Likes
Monnat Systems,

I forgot to mention one important cause of the bug.  My (standalone) APs are all in Manhattan and the noise is incredible.  You can detect over 300 radios fighting for 2.4G and 5G channels.  What I presume happens is that ChannelFly becomes overloaded, spikes the CPU, and after a certain threshold of spiked CPU the kernel forces a reboot.

Without seeing the source of the ChannelFly logic, I cannot say for sure, but when ChannelFly is disabled, I have absolutely no reboots.  If I enable it, I am guaranteed to have a reboot occur within 24 hours.  This would explain the “random” or “sudden” experience of reboots: since I believe that the CPU spike is based on reactions to outside noise from ChannelFly.

If you’re operating in a reasonably quite environment, this bug would probably not present itself.

Adam
Photo of Monnat Systems

Monnat Systems, AlphaDog

  • 714 Posts
  • 151 Reply Likes
adam,

indeed its a gap in the channelfly specific to your situation. make sense to me.