R500 internet speed slower than ISP provided.

  • 1
  • Question
  • Updated 2 months ago
  • Answered
I setup 2 R500 as a mesh network and using 1Gb boradband network. I find that the connection speed dropped to around 400Mb for Cat6 cable connection and 200Mb for Wifi 5G connection (80 Hz) when I connected internet via R500. I tried to connect my notebook to ISP modem directly and got >900 Mb speed. 
What could I do to improve the performance?
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 379 Posts
  • 132 Reply Likes
Hi Joshua,

There are several factors in this which can support speed behind a mesh network.
  1. Speed you are getting on ethernet may or may not be equal on WiFi because WiFi is a half duplex mode of communication, unlike full duplex in Ethernet/wired network.
  2. Speed depends upon client supportability, compatibility, multipath (if using multiple spatial streams).
  3. R500 can max support upto 2 spatial streams so your client should also support it.
  4. Now if we talk a about WiFi speed behind a mesh AP then lets consider below.
Topology:

Ethernet network/SW <<<<>>>>> A-Root AP(hardwired) -B <<<<>>>>> C-Mesh AP (WiFi bridge mode)-D <<<<<>>>>> E-Clients behind Mesh APs.

On above ideally you should get below speeds on each points

A- 1Gig over ethernet to Root AP
B- Upto 867 Mbps max over WiFi to any wireless device connecting to this AP directly.
C- Half speed of max speed of Root AP. Means 867Mbps/2= 400 Mbps~
D- AP can provide maxi speed/2 upto what it is receiving from mesh uplink (from root AP).
E- Clients can reach max 400 as that is the limitation introduced by mesh link (last mesh hop).

With each mesh hop, speed will decrease by half from its last hope. Means connecting a 2nd AP to mesh AP will further reduce the speed to 400/2.

I hope it is clear now why you are getting less speed.

If you are getting low speed on root AP then please check how close you are to AP, check if client supports 80MHz on 5G band, etc.

Regards,
Syamantak Omer
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 379 Posts
  • 132 Reply Likes
Are you also getting low speed when your laptop directly connected to 2nd port of the AP? If yes then could you confirm what is the firmware on APs.

Regards,
Syamantak Omer
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes
Thanks for helping!

Yes, the speed is just around 400 Mbps even my laptop directly connected to Root AP's 2nd port.

The firmware on APs is 200.7.10.202.118

Regards,

Joshua
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 379 Posts
  • 132 Reply Likes
Hi Joshua,

Could login to root AP CLI and share output of below commands.

If root AP is Master AP then:

enable
ap-mode
get eth
get eth eth0
get eth eth1

If it is member AP then:

get eth
get eth eth0
get eth eth1

Also try with a different laptop/desktop to check the speed.

What speed test app you are using to measure speed? Could you try using iPerf and see if you get better output?

Regards,
Syamantak Omer
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes
Hi Syamantak,

Here is the output. Thanks for helping.


ruckus(ap-mode)# get eth


Port  Interface  802.1X  Logical Link  Physical Link      Label
-----------------------------------------------------------------
0     eth0       None    Up            Up 1000Mbps full   10/100/1000 PoE
1     eth1       None    Up            Up 1000Mbps full   10/100/1000


Note: Read Port#N as N+1, if you are referring this CLI output with AP's "Configure :: Ethernet Ports" UI Page.
OK
ruckus(ap-mode)# get eth0
Command is not recognized: get eth0
ruckus(ap-mode)# get eth eth0
Ethernet state of Interface eth0: Enabled
OK
ruckus(ap-mode)# get eth eth1
Ethernet state of Interface eth1: Enabled
OK
ruckus(ap-mode)#
Photo of hayk

hayk

  • 387 Posts
  • 60 Reply Likes
Joshua,  are you using the root node as bridge or gateway mode?
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes
I am using it as gateway mode
Photo of hayk

hayk

  • 387 Posts
  • 60 Reply Likes
Yeah,  you really need to turn off gateway mode and have it in bridge mode which is when gateway mode is checked off. You should either use the isp router as a router or get a wired router that can handle gigabit. When you use the ruckus r500 in gateway mode there’s a bit of overhead so it can’t route as much when doing WAN to LAN. Most people use ruckus APs in bridge mode. This should address the wired performance.
(Edited)
Photo of hayk

hayk

  • 387 Posts
  • 60 Reply Likes
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes
OK,thanks for helping.
How can I turn off gateway mode without reset it? I can't untick the it.
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 249 Posts
  • 92 Reply Likes
Hi Joshua,

I  don't think you can change the AP mode from gateway to bridge.

You have to factory reset the APs and reconfigure Unleashed to bridge mode.

Regards,
Syamantak Omer
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes
Thank, 
Do I need to reset the mesh AP too if I want to change the root AP to bridge?
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 249 Posts
  • 92 Reply Likes
Please try copying mesh configuration from Unleashed (current settings) and when you reconfigure master AP then use the same mesh configuration (mesh SSID name and passphrase). I think mesh AP should be able to communicate to root.

Just in case if above does not work, please factory reset the mesh AP for reconfiguration.

Regards,
Syamantak Omer
(Edited)
Photo of Joshua Sin

Joshua Sin

  • 7 Posts
  • 0 Reply Likes
Thanks for helping
Photo of Syamantak Omer

Syamantak Omer, Official Rep

  • 249 Posts
  • 92 Reply Likes
Happy to help! :)

Regards,
Syamantak Omer