R500 AP join ZD 1100, Failed to upgrade AP Image from 104(AP) > 9.9 (ZD)

  • 1
  • Question
  • Updated 3 months ago
Currently we are running ZD 1100 with 9.9.1.0.31 with old APs. We couldn't update firmware above 9.9.0.1 as the current APs are not compatible with more update ZD firmware. However, we are unable to add additional APs (R500, firmware : 104.0.0.1347) to current ZD 1100. The error message is "Fail to upgrade AP [XXXXX] image from [104.0.0.0.1347] to [9.9.1.0.31]".

When I go to configure AP through ZD, the message "The Access Point is not yet approved and connected. Click "Allow" action (if present) and wait for the AP to complete connection".

Are there any steps missed in setting up AP / ZD, or 104.0.0.0.1347 required more update ZD firmware? Thanks.
Photo of Felix Wong

Felix Wong

  • 2 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Michael Brado

Michael Brado, Official Rep

  • 2413 Posts
  • 332 Reply Likes
Hi Felix,

   Yes, the ZoneFlex R500 is supported on ZD 9.9.1.0.31 release, if you have enough
AP licenses, and it can communicate with your ZD.  Look on your Dashboard tab, and
under Licensed APs for the maximum your ZD can manage, then under Devices Overview
where it shows your current # of APs.  Are you within limits?
    Next, from your message above, go to the Configure tab, Access Points page, and in
the third box down, Access Point Policies, there is a checkbox to "Automatically approve"
all join requests from APs.  This sounds like it might be important, based on your message
above.  In the top Access Points section on this page, do you see an option to click/approve
a pending AP?  Good luck and best regards.
Photo of Felix Wong

Felix Wong

  • 2 Posts
  • 0 Reply Likes
Thanks for your reply. We have 12 licensed AP with 10 APs (ZF7321) currently connected and works fine. Tried above said solution but still unable update AP firmware image from [104.0.0....] to [9.9.1....].

Checked the AP LOG, found the message "daemon.emerg Firmware Daemon[948]: _check_new_image_hdr, Cannot upgrade image due to flash incompatibilty".

Thanks.
(Edited)
Photo of Philip Au

Philip Au

  • 3 Posts
  • 0 Reply Likes
I can say we tried. but the new R500 comes with new firmware that cannot be downgrade to 9.9. Luckily we upgrade our ZD.