R310 standalone doesn't provide IP address on guest network

  • 1
  • Question
  • Updated 5 months ago
Hi all,

We have a single R310 AP running standalone. First Wifi network is our company network, running on default VLAN0001. This works fine out of the box. Second Wifi network is a guest network (VLAN0020) I configured. The R310 is connected to a switch (port 23). It's port is configured to allow VLAN0001 and VLAN0020. It's also configured as a 'trunk' port. There is a second port in VLAN0020 on the switch (port 24), which is connected to our firewall. The firewall provides IP-addresses for clients on the VLAN, because it acts as a DHCP server.

My problem is that clients on the guest wifi network don't get an IP-address from the DHCP-server and therefore can't connect.

When I configure a third port in VLAN0020 on the switch and connect a client to it directly (Windows 10 laptop), it does get an IP-address, so the DHCP server is supplying addresses on the VLAN0020. 

What do I need to configure for the R310 to provide the guest network clients with an IP-address from the DHCP server?

Thanks in advance!
Photo of Raymond Brink

Raymond Brink

  • 2 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Abi

Abi

  • 77 Posts
  • 38 Reply Likes
Hi Raymond,

Pls check the port settings on AP and make sure it is in Trunk, also I assume VLAN 20 is tagged on Guest WLAN.

If you are okay please use Unleaded firmware it has lot more features than Standalone and can be managed through APP even remotely you just have to Link the APP to your social login or Gmail account.

Thank you.

Regards,
Photo of Raymond Brink

Raymond Brink

  • 2 Posts
  • 0 Reply Likes
Hi Abi,

How would "check the port settings on AP and make sure it is in Trunk"? Where do I go in the web interface?

Thanks!
(Edited)