R310 IP Conflict with Windows Desktop

  • 1
  • Question
  • Updated 5 days ago
Both R310 and Windows Desktop are directed connected to the ISP Router. However, we are facing daily network failures due to "conflict of ip".

We set a static ip for our R310 and excluded the ip from the DHCP pool. It went well for about a week after which the same issue occurred again.

This is happening in my customer's shop and there is no way they could wait for us to arrive to troubleshoot when the internet is down as they require the internet to process payment.

Are there any troubleshooting tips for this issue?
Photo of Jiaming Lau

Jiaming Lau

  • 2 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Alexey

Alexey

  • 7 Posts
  • 0 Reply Likes
Hi
I do not think that the trouble reason is RUCUS APsettings. You should challenge your LAN. Maybe someone else sends DHCPOFFER?
Photo of Alexey

Alexey

  • 7 Posts
  • 0 Reply Likes

Change DHCP pool to take the static addresses from the end of network. E.g. 192.168.1.1-192.168.1.22 is the pool & 192.168.1.222 & 192.168.1.233 are static addresses for desktop & AP.
Photo of Lou Kalis

Lou Kalis

  • 14 Posts
  • 2 Reply Likes
Set a static on the client desktops, check both Ethernet and Wireless Nic’s... release dhcp using the command prompt.

“Click Start->Run, type cmd and press Enter. Type ipconfig /release at the prompt window, press Enter, it will release the current IP configuration. Type ipconfig /renew at the prompt window, press Enter, wait for a while, the DHCP server will assign a new IP address for your computer.”
Photo of Victor Cenac

Victor Cenac

  • 6 Posts
  • 1 Reply Like
Yes, this is clearly a DHCP issue. You may want to look over the settings to see if you can "reserve" the AP IP with its MAC address. That way that particular IP will only handed out to the AP. You can do the same with desktops, too.
It would seem that the AP may behaving as BOOTP, where it does not renew its lease before expiration. Thus, the DHCP is giving that IP to a new requester.
Photo of Jiaming Lau

Jiaming Lau

  • 2 Posts
  • 0 Reply Likes
Hi all,

The IP conflict issue has been resolved.

We have reserved both IPs 192.168.1.253 and 192.168.1.252 to the AP and desktop respectively. 1.254 remains as the default gateway.

However, we are still facing intermittent downtime of the internet. We would then have to either restart the router or we have to unplug the R310. The former will result to a similar downtime after a few hours and the latter will resolve the issue.

Would like to check if it is still a DHCP issue?

Please advise.

Thank you.
Photo of Victor Cenac

Victor Cenac

  • 6 Posts
  • 1 Reply Like
It sounds like you need a different router there. This smells like the arp table is getting full, or the MAC learning is having a similar issue. We had an issue with a switch (router really) that would not flush the MAC table. The switch would learn every MAC of every device that drove by our building and then would stop forwarding, since it could not maintain its MAC table.
I would blame it on either a bad router or bad firmware. Maybe you want to re-flash it.