R300 + Draytek 2925 Multiple SSIDs, VLANs, island SSID and failed internet connection

  • 1
  • Question
  • Updated 1 year ago
Hey all,

This is the first time I'm working with VLANs and stuff so forgive me my noobness :)

The situation:
I got a Ruckus R300 AP connected on port1 to a Draytek Vigor 2925 (non WiFi version). The Draytek is connected to my internet cable modem which has IP 192.168.0.1 and DHCP enabled.
For the DrayTek and Ruckus R300 settings check the images below.

What I would like:
Create 3 SSIDs with a different seperated network for each SSID; 2 password protected and 1 open for guests

What I got working:
Well basically after hours of trial & error I got everything working except for the internet status connection on my R300 that says (disconnected) which I think leads to the R300 sending out an "island-XXXXXX" SSID. From my Google experience this is because the R300 can't access the gateway or is still in factory default mode. As you can see in the following image the Connection Status is down.


Internet connection settings on the R300:

Local Subnet1 on R300:

Local Subnet2 on R300:

Local Subnet3 on R300:

VLAN Configuration on Draytek Vigor 2925


LAN General Setup on Draytek Vigor 2925


Details Page LAN1 from above image:


Details Page LAN2:

Details Page LAN3:


These are the WiFi settings for the guest network on the R300.
I named the WiFi networks according to the VLANs to make things a bit easier. to remember. So the VLAN10 network is set to Local Subnet 1, VLAN20 to Local Subnet 2 (see image below) and VLAN30 to Local Subnet 3.


So everything is working just fine but I have a feeling I have missed a few steps. I tried disabling the "island-XXXXXX" by logging in to the R300 via SSH and perform the following CLI commands:

set state wlan102 down
set state wlan103 down

This works however, after I powercycle the R300 the "island" SSID pops up again.
Sorry for the long post, if there is any more information you need please let me know.

Thanks in advance for your support!
Photo of Lilacrazor

Lilacrazor

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of raymond brink

raymond brink

  • 1 Post
  • 0 Reply Likes
Hey you've been working? I have the same problem
(Edited)