Q-in-Q Ethertype Configuration for SmartZone?

  • 1
  • Question
  • Updated 2 months ago
Hi,

I'm in the process of configuring a 2 node SZ300 Cluster for a large-scale deployment which needs to use q-in-q. I was made aware that it's possible to set this within individual SSIDs now which is great for what I want to achieve, however where I'm struggling is how I can set the ethertype.

I'm testing with a Ruckus ICX switch and on that have the edge configured with ethertype 0x9100 so I need to replicate that. 

Looking through the documentation I've not been able to find much. I can see that there is a SmartZone CLI command "show running-config q-in-q-ethertype" but this returns nothing configured. What I can't find anywhere is the command to actually set this up, nor where exactly I need to set it (domain/zone/wlan etc). Has anyone tried this before? Help!

Thanks,
Andy
Photo of Andrew Buick

Andrew Buick

  • 4 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Genrikh Bakhman

Genrikh Bakhman

  • 5 Posts
  • 0 Reply Likes
Hello.

Which version do you use? 

The example below based on vSZ-H 3.6.1.

Go to SSID settings and make sure that WLAN tunneling is active and Core Type is Bridge. After that go down to the section "Advanced Options" and mark the checkbox QinQ Enable.

See attached screenshots.




 

Photo of Andrew Buick

Andrew Buick

  • 4 Posts
  • 1 Reply Like
Hi Genrikh,

Thanks for your reply! This is on 5.0.0.

I have the Q-in-Q side of things enabled on the WLANs as in your example above, but I need to be able to change the ethertype being used in the frame otherwise I don't think it will work as the AP won't be able to remove the q-in-q header created by the switch. Effectively I will have an outer VLAN tag using ethertype 0x9100, and then an inner VLAN tag using the standard 802.1Q ethertype of 0x8100. I am in the process of testing so I will update here if it works anyway, I just need to understand if there is a way to manually set the ethertype as well as the SVLAN etc.

Thanks,
Andy
Photo of Genrikh Bakhman

Genrikh Bakhman

  • 5 Posts
  • 0 Reply Likes
We have only SCG 200 in the lab with sw 3.4.1. As I see, there is possible to change ethertype only for third party AP zone.

Maybe in the release 5.x there are more options for that.


Photo of Andrew Buick

Andrew Buick

  • 4 Posts
  • 1 Reply Like
Many thanks Genrikh for the responses! Unfortunately due to the change of GUI, this option doesn't seem to be there on 5 but I have Ruckus looking into it as well. I'll update on here as I get it figured out.