Problems with login page for users with Apple devices

  • 1
  • Question
  • Updated 3 months ago
  • Answered
The normal way is, that our hotel guests connect their device with the wifi network and the browser opens automatically the login page. If not, users start browser manually, put in any website url, for example Google and than they can see the login page.

This works not for users with Apple devices. Apple user can connect to wifi network, but they can not open the login page. The only option is, that this users have to start their browser manually, but in the ip adress from router and than they can see the login page.

Its not the best way, because at cherck-in i have to ask every guest, if he have an Apple device and explain them this situation with ip adress.
Photo of pixilla

pixilla

  • 1 Post
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Andrew Giancola

Andrew Giancola

  • 78 Posts
  • 21 Reply Likes
In your 'walled garden' if *.apple.com is allowed through then the apple connectivity check may not work. Not sure if that's your issue, it was one of mine once.
Photo of Karl Lavender

Karl Lavender

  • 16 Posts
  • 3 Reply Likes
Note that we also recently discovered a certain version of Apple OS... 12.4.x... I dont recall the exact version, but they changed something on their back end that is affecting how captive portal is working for Apple.  If you have a personal device that is experiencing the issue, try force the latest OS update, or go back one version and see if it still occurs.

If its not version specific, then you may need to check what Andrew suggested above and ensure that .apple and their captive portal addresses are not whitelisted through your network.
Photo of David Black

David Black

  • 56 Posts
  • 26 Reply Likes
Have you checked the Bypass Apple CNA setting on the guest network?  Configure/WLANS/ toward the bottom under "Bypass Apple CNA" uncheck all the boxes.  If you have a walled garden configured, make sure that captive.apple.com and *.apple.com are not allowed.  

Another option is to simply forget the captive portal and set up a PSK network and apply an ACL that allows internet only (blocks all private addresses).