Problem hotspot(WISPr) in VSZ-H

  • 2
  • Question
  • Updated 4 months ago
Hello,
When configuring hotspot mode (WISpr) in VSZ-H version 3.4.2.x, it is not possible to access the captive portal. 
Do not load any portal or service. This was done locally and externally with an AAA server, and in neither way has it worked. Thanks for the help
Photo of Dimitri Stakov

Dimitri Stakov

  • 25 Posts
  • 1 Reply Like

Posted 1 year ago

  • 2
Photo of Dmitry Ivanko

Dmitry Ivanko

  • 13 Posts
  • 0 Reply Likes
Hi,

it works fine, my version is 3.2.1. Build 3.5 works fine too. Do you have the external or the internal Login URL WISPr setting? Check if you add hosts(dns, web server etc) to walled garden...
Photo of Anthony Anyoti

Anthony Anyoti

  • 2 Posts
  • 0 Reply Likes
Hi Dmitry,

Am facing the same issue with vsz-H. I am able to open the captive portal when i input the URL manually into a browser on the UE. So the main problem is the automatic redirect once a user connects-it just doesnt happen.

I have tested the walled garden domains and IP's which work fine, just the actual redirect. 

Any assistance would really be appreciated.

Thanks
Photo of Dmitry Ivanko

Dmitry Ivanko

  • 13 Posts
  • 0 Reply Likes
Hi Anthony,

will you get a redirect with http status 302 when you try to open URL? You can see it in a browser. See the place marked red

Photo of Anthony Anyoti

Anthony Anyoti

  • 2 Posts
  • 0 Reply Likes
Hi Dmitry,

No I do not, only error 304, this is after I enter the URL manually.

Photo of Dmitry Ivanko

Dmitry Ivanko

  • 13 Posts
  • 0 Reply Likes
There are two possibilities
  • smart client is disabled. A client must force an HTTP request manually for example by a browser to get a redirect.
What's happen when you try open for example http://i.ua?
If you are redirected - you need to enable the smart client. You can start to read about this http://blog.erratasec.com/2010/09/apples-secret-wispr-request.html#.Wp6KAZPFJi8
Photo of Dimitri Stakov

Dimitri Stakov

  • 25 Posts
  • 1 Reply Like
hello Dmitry Ivanko,

The solution in my case was:
1. Install the vSZ-H controller in its version for three interfaces: Control, administration and cluster.
2. Configure an ip from the public domain (xxx.xxx.xxx.xxx) to which the APs are set. set scg ip xxx.xxx.xxx.xxx.
3. Change firewall policies where ports 8099, 8090 are open.

Regards
Photo of Luuk Haijes

Luuk Haijes

  • 1 Post
  • 0 Reply Likes
Hi Dimitri, can you give some more information how you set it up. it's still a bit unclear to me. I have the same problem and I can't figure it out how to fix it..

Thanks in advance